Support » Fixing WordPress » index file situation

  • A few months ago I built my site and installed WordPress.

    I do not currently have all the original copies of my files due to formatting.

    So, today i wanted to make a few simple changes to the site, so I downloaded the index.html file, made the changes and uploaded it.

    Nothing changed (theres an index.php file).

    So, I tried a few things such as temporarily removing the php file to no avail (site does not look like i want it to). Everything comes back to normal with the index.php file.

    So I remembered what i did a while ago that the actual index file isn’t the one in the local folder, but within wp-admin or wp-content or the like…

    can you please refresh my memory as to what or where i need to place my new index.html file so the changes i make are validated.

    Thanks in advance

Viewing 3 replies - 1 through 3 (of 3 total)
  • You probably want to edit the index.php in your theme directory, nowhere else. Check your server settings (consult your host or sysadmin) for directory index load priority. e.g. home.php and index.html will typically trump index.php

    WP runs on php

    As far as I am aware the only .html file you should have on a wordpress installation is the readme.html in the root folder.

    Thanks a lot Mark, you have solved my situation

    the file i needed to edit was my squeezepage which is squeezepage.php which is located in the theme directory!

    Thanks Again

    Laith

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘index file situation’ is closed to new replies.