Support » Fixing WordPress » index-extra.php dashboard error

  • Asukavalentine

    (@asukavalentine)


    Hello
    I just upgraded my wordpress to 2.2 version and this error it’s showing in dashboard:

    You don’t have permission to access /wp-admin/index-extra.php on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    I can’t see incoming links or news, everything it’s with this error.
    I saw a topic opened with this but doesn’t help, it says something about k2 themes that I think I’m not using.
    Any help will be really apreciated.
    Thank you!

Viewing 14 replies - 16 through 29 (of 29 total)
  • Asukavalentine

    (@asukavalentine)

    Help in the topic I found this morning didn’t work, I asked support for change it in my server and now I can’t post in the blog:

    Forbidden
    You don’t have permission to access /wp-admin/post.php on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    ——————————————————————————–

    Apache/1.3.37 Server at http://www.bellsoffreedom.net Port 80

    I will ask them for put it back to normal and try Deerhunter’s option.

    loudestnoise

    (@loudestnoise)

    I know how to edit the .htaccess file, but when I add

    <Files index-extra.php>
    SecFilterInheritance Off
    </Files>

    I get a 500 Internal Server Error

    Where do I add this and does it matter with the order?

    Deerhunter04

    (@deerhunter04)

    I have my .htaccess in the root folder of my webserver. For me, that is the public_html folder. I do not have a .htaccess file in my wordpress directories.

    That is the only thing i have in my .htaccess file, so i’m not sure if there is a specific order or not. I really doubt the order matters at all.

    geneome

    (@geneome)

    The .htaccess hack was the key for me.

    @loudestnoise
    For my .htaccess in my wordpress folder (www.mysite.com/blog) I have this in it:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /blog/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /blog/index.php [L]
    </IfModule>

    <Files index-extra.php>
    SecFilterInheritance Off
    </Files>

    # END WordPress

    moshu

    (@moshu)

    Whatever htaccess thing you want to be applied to your WP install – the file has to be in the WP’s root, not the site’s root.

    Deerhunter04

    (@deerhunter04)

    I’m not sure what to say Moshu, but my .htaccess is in my site’s root and it solved my problem. I’ll play around with it. Maybe i did another change that is working and i’m thinking it’s the .htaccess.

    Glad everything is working for you guys.

    qivlie

    (@qivlie)

    thanx for all, it fixed my troble.
    remember put the code in first line in .htaccess file
    e.g:

    # -FrontPage-

    <Files index-extra.php>
    SecFilterInheritance Off
    </Files>

    IndexIgnore .htaccess */.??* *~ *# */HEADER* */README* */_vti*

    <Limit GET POST>
    order deny,allow
    deny from all
    allow from all
    </Limit>
    <Limit PUT DELETE>
    order deny,allow
    deny from all
    </Limit>

    πŸ˜‰

    I have tried most versions of the .htaccess-fix but keep casuing an internat server error which ever way I do it. Could this mean there is simply something with the the settings on the server that don’t allow a modification like this?

    Most things do work, of course, but itΒ΄s a little frustrating πŸ™‚

    We have the same frustrations. Mine doesn’t work either.

    Ok, new additional problem. All of the sudden the pages can not be accessed at all. 404 Error. Wonder what is going on?

    The last problem resolved. After having replaced the .htaccess-file with the original one the pages can be accessed again. Sorry for the confusion πŸ™‚ Thought I had already replaced it. The problem with the dashboard remain, though …

    I know how to edit the .htaccess file, but when I add

    <Files index-extra.php>
    SecFilterInheritance Off
    </Files>

    I get a 500 Internal Server Error

    Where do I add this and does it matter with the order?

    when ever I monkey with the htaccess, and I get a 500 error, I make sure to save the code with the proper format.
    “raw text” or “unix code”.
    Your text editor might be messing you up there.

    This problem has happened on a clean-new install for me as well. The htaccess addition fixed it.

    OK. I’m running wp 2.2 on a windows 2003 server; IIS 6. Site: grace.cardwellcreative.com. I’m having a similar, but slightly different issue with the Dashboard. Mine seems to be related to the Event Calendar plug in (version 3.1). I only get the dashboard error when the EC3 plug in is activated.

    The error I see in the dashboard reads:
    “CGI Error
    The specified CGI application misbehaved by not returning a complete set of HTTP headers.”

    We have narrowed it down to a problem with the index-extra.php file. As I said, though, if I disable the EC3 plug in, all is well. Hope this helps someone (and hopefully me).

    i had the same problem with 2.2, i created a text file and put this

    <IfModule mod_security.c>
    SecFilterInheritance Off
    </IfModule>

    save this txt file, then rename the file .htaccess and upload it into your wp-admin foledr, refresh your dashboard and the problem will be fixed, i also had a problem with categories, it didnt allow me to ad categories and posted the same error of forebidden thing, then it was also fixed, thanks guys for the tip!!

    nacho

Viewing 14 replies - 16 through 29 (of 29 total)
  • The topic ‘index-extra.php dashboard error’ is closed to new replies.