Support » Fixing WordPress » index-extra.php dashboard error

  • Hello
    I just upgraded my wordpress to 2.2 version and this error it’s showing in dashboard:

    You don’t have permission to access /wp-admin/index-extra.php on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    I can’t see incoming links or news, everything it’s with this error.
    I saw a topic opened with this but doesn’t help, it says something about k2 themes that I think I’m not using.
    Any help will be really apreciated.
    Thank you!

Viewing 15 replies - 1 through 15 (of 29 total)
  • I’m having the same problem. I want to know how to fix this as well.

    Same thing here. I even installed a brand new copy just to test and I got the same error. Here is what i’m running:

    – WordPress 2.2
    – Apache 1.3.37
    – PHP 4.4.3
    – Mysql 4.1.21

    no one?

    Whew! It’s not just me then. I’m having the same issue… tried everything I know. Reinstalled it, changed the permissions of the file, reset my options… and still the dashboard is messed up.

    I never have problems when upgrading to new versions of WP, but I am experiencing this issue too. It is quite annoying, and I too have tried re-installing a couple of times.

    Same issue. Proving to be a right pain, in that my custom error pages are being called and the sheet-style etc are making the dashboard unusable.

    Until someone posts a fix, i have just removed a chunk of script towards the top of the index.php file (in wp-admin) that seems to call the files.

    It more or less deletes the three areas so its not a long them fix – just makes it look nice if you *need* to use it.

    Ross.

    Ya, so deleting

    <script type="text/javascript">
    Event.observe( window, 'load', dashboard_init, false );
    function dashboard_init() {
    	var update1 = new Ajax.Updater( 'incominglinks', 'index-extra.php?jax=incominglinks' );
    	var update2 = new Ajax.Updater( 'devnews', 'index-extra.php?jax=devnews' );
    	var update3 = new Ajax.Updater( 'planetnews', 'index-extra.php?jax=planetnews'	);
    }
    </script>

    makes it stop. I guess this is part of the new AJAX added in 2.2 but it causes the index.php to go wacky

    did you delete the exiting files and then upload the new files inside wp-includes/js ???

    I cannot reproduce that EXACT error because I suppress error messages, however I can break my dashboard display by essentially deleting that particular directory.

    95% of upgrade problems seem to be with people not following directions.

    yes, i did. furthermore, dashboard breaks on clean install (not upgrade).

    welp, it doesnt break for me, either with an upgrade or a clean install. dunno.

    I’m having the same problem 🙁 If I show index-extra.php it works correctly but in Dashboard don’t work 🙁

    Thanks for the link Asukavalentine. That helped me out a ton. I went ahead and edited my .htaccess in my root directory and added this:

    <Files index-extra.php>
    SecFilterInheritance Off
    </Files>

    That fixed my problem. I didn’t want to turn off mod_security for the entire wp-admin folder, so this way just turns it off for index-extra.php file.

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    None of this stuff is new to 2.2. It was all there in 2.1.3 as well. I think there’s some other kind of major issue you’re having here. Probably a bad html_type or something.

    Well, something must have been changed. I was running 2.1.3 without any problems, did the normal upgrade like i always do, and began having problems with 2.2.

Viewing 15 replies - 1 through 15 (of 29 total)
  • The topic ‘index-extra.php dashboard error’ is closed to new replies.