WordPress.org

Support

Support » How-To and Troubleshooting » [INDEX] Custom queries & DISQUS Seems not to work

[INDEX] Custom queries & DISQUS Seems not to work

  • Hello! I am new here, I’ve been trying to get this thing to work in quite a while, but can’t seem to get it to work or find any solution that works for me either.

    Ok I got 2 custom queries, 1 that shows the very latest and one that shows the rest, the one that shows the very latest is not displaying the comment count or the reactions, but the other query seems to do just fine.

    this does only occur on the index of course.

    Anybody knows what can cause this?

    [No bumping. If it’s that urgent, consider hiring someone.]

Viewing 5 replies - 1 through 5 (of 5 total)
  • I can’t seem to find any solution out there, I would appreciate if someone could figure this out or had a similar problem? If anybody want to see some code, I can provide you that.

    This is really bugging me, would appreciate some support am I really the only one with this problem :)?

    Yes.

    i have the same problem you are not alone.

    the problem with the site I’m working on is like this:

    I have a CPT books. In the single-books page there is another loop showing others books of the same writer. even though I use $my_new_loop->have_posts() syntax it detects it as the main query or something.
    I looked at the disqus source and I think it has got something with “loop_end” action they use

    I’m working on this, I’ll let you know if I manage to solve (by the way haev you solved it since)

    OK got it!

    For those who may encounter:
    After the custom query I added two reseting functions and voila

    wp_reset_query();
    wp_reset_postdata();

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[INDEX] Custom queries & DISQUS Seems not to work’ is closed to new replies.
Skip to toolbar