Support » Plugin: Enlighter - Customizable Syntax Highlighter » Indentation is not working

  • neo4evr


    I am using Enlighter to highlight my website codes. However, the indentation is not working at all on any Enlighter theme. I have no clue why.
    Can you please help me out in fixing this issue?

    Many thanks!

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Andi Dittrich


    try a different WordPress theme and remove any kind of “optimization” plugins – some function seems to remove the indentation within the html code. debugging such issues takes quite a long time..

    Which editing mode do you use ? Gutenberg/TinyMCE/shortcode ?

    Thread Starter neo4evr


    I use Gutenberg editor. And using LiteSpeed cache plugin. If I disable it then the site is slowing down a lot. 🙁

    Plugin Author Andi Dittrich


    does it work as expected with disabled caching plugin ?

    we have the same problem.
    I just disabled caching with WP Rocket on a page and cleared the cache but indentation does not come back.
    We have enabled: “change tabs to spaces”.
    Using Gutenberg with Generate Press Premium with Generate Blocks Pro.

    Any idea?

    Thank you,

    Plugin Author Andi Dittrich


    not really, it’s something related to a third party theme/plugin. i’m unable to reproduce the behaviour within a clean WP5.8 setup.

    the “regular” method to debug such issues is to disable all other plugins within a test/staging env to identify the “weak” one (it’s mostly some kind of “optimization” setting..). if this doesn’t help change the theme to a standard one – if this last “method” works the issue is related to the theme.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.