Incremental upgrade from 2.2.3 to 2.7.1, can't access main page (6 posts)

  1. SchneiderBee
    Posted 5 years ago #

    I recently set up a company blog. Our hosting company installed WordPress 2.2.3 for us and then offered to upgrade to version 3 (for a fee, of course). I've been doing the incremental upgrades and managed to get up to 2.6.5. Any higher than that and I run into this problem:

    1. I cannot access the main page of the blog. I get this browser message: "Firefox has detected that the server is redirecting the request for this address in a way that will never complete."
    2. I can access the admin panel.
    3. I can access individual blog posts through the admin panel
    4. However, clicking 'view site' at the top of the panel doesn't do any good.

    I have tried installing 2.7 and 2.8 to see if this is specific to the release. I've erased cookies, renamed the .htaccess files, shut off my plugins, and switched my theme back to default. What have I not done yet?

  2. esmi
    Forum Moderator
    Posted 5 years ago #

    Increased the memory available to PHP?

  3. SchneiderBee
    Posted 5 years ago #

    Just tried this one:

    2. If you don't have access to PHP.ini try adding this to an .htaccess file:
    php_value memory_limit 32M

    Ooh, that caused an internal server error. I deleted my wordpress files and reloaded them, that fixed that particular error. I'll have to try the other methods on Tuesday.

  4. SchneiderBee
    Posted 5 years ago #

    I tried adding:
    define(’WP_MEMORY_LIMIT’, ‘256M’);
    to my config file and I still got the same result: access to the admin panel but my homepage wouldn't load.

    This particular advice gave me pause because when I e-mailed my host they replied that "some changes need to be made to the config files" and details could be found on the wordpress forums. Anyone know where these details could be??

  5. esmi
    Forum Moderator
    Posted 5 years ago #

    Increasing the memory is the only usual change that is sometimes needed.

  6. SchneiderBee
    Posted 5 years ago #

    Ah-ha! I found this topic http://wordpress.org/support/topic/upgr-to-wp-281-php-is-sending-my-browse-loc-outside-my-wordpress-folder

    I had to add a couple of lines to the config file defining the homepage and then install a plugin that disabled the canonical redirect. That plus the memory bump cleared up the problem, though I'm not exactly sure how. Whew!

    Thanks for taking the time to help!

Topic Closed

This topic has been closed to new replies.

About this Topic