WordPress.org

Support

Support » How-To and Troubleshooting » Incredibly slow–followed all advice

Incredibly slow–followed all advice

  • Hey everyone!

    I’m new to the WP world. I have a client who is having a bit of an issue and was hoping that someone might have some tips on how to fix it. We have a client who is running a a WordPress blog under a subfolder. Her WordPress is EXTREMELY slow and sometimes (usually a 50/50 chance) times out. I’ve done some research and here’s what I’ve done to try to help speed it up:

    – Upgraded her WordPress. She was running a full version behind.
    – Tried installing WP Super Cache (and W3 Total Cache), but they aren’t helping. In fact, they make it where the blog roll doesn’t appear.
    – She’s got the following SEO plugins: All in one SEO Pack, Google Analyticator, Google XML Sitemaps.

    She’s running on GoDaddy. Now I know that sometimes hosting can play an issue, but I don’t think it’s them. The rest of her site (not the WordPress side) is running quick.

    Anyone else have any tips? Thanks! 😀

Viewing 15 replies - 1 through 15 (of 16 total)
  • Site URL?

    Hey Krishna! Here’s the URL: http://familyfirstseniorcare.com/blog/

    Can you reinstall or deactivate WP Super Cache? It is broken, and reinstalling a freshly downloaded copy may help. If it does not, rename your plugins folder and test speed.

    I’ll give that a shot! 🙂 Right now I’m having trouble trying to get it from stopping to time out. I keep getting a 500 error.

    Testing tools show timeout error. But, though slow, the blog loads.
    Did you rename the plugins folder?
    Can you login to the dashboard?

    If so, can you deactivate the plugins (if not done and revert to the WordPress default theme and see if it helps?

    Backup everything first, including your database.

    Hey Krishna!

    I did rename the plugin folder for Super cache. WP seemed to be able to delete it anyway. It’s deleted. I’m gonna try to re-install it.

    I can get to the Dashboard only sometimes. At times, it will kick me back out to log back in.

    Really appreciate your help! 🙂

    Moderator Mark Ratledge

    @songdogtech

    @abellefeuille: You’re on GoDaddy, who is well known to be very slow and problematic. Search these forums for issues with them. See Recommended WordPress Web Hosting

    Hey Songdogtech!

    I realize that, but they haven’t had this problem before until the SEO packages were installed I guess. And the rest of the site is running fast–just not the WP side. 🙁

    If you view the source of your site (when it eventually loads) you’ll see a comment at the bottom:
    WP Super Cache is installed but broken. The constant WPCACHEHOME must be set in the file wp-config.php and point at the WP Super Cache plugin directory.

    That said, something else is probably awry. I would turn off the caching plugin so as not to cloud the issue.

    If your site is still slow, I would do the usual first debug steps: try a standard theme (twentysomething). If that makes no difference, disable all you plugins and reactivate one by one, checking everytime.

    My guess right now would be that something is doing a massive DB query.

    Hey Vancoder!

    I’m trying to do what you are suggesting, but I can’t get into the dashboard at all now. It keeps kicking me out. 🙁 I’ll keep you updated.

    Thanks for the tips!

    Can you login to your hosting account? Or use FTP? If yes, you need not have access to dashboard to rename the plugins folder (add -old or something like that) and revert to the default WordPress theme). That will help you eventually to get over the problem and gain access to dashboard. If everything fails, reinstall WordPress manually, excepting wp-content.

    Backup everything, including your database.

    Hey Krishna!

    I backed everything up (I do have FTP access). I renamed the plugin folder. That didn’t work. I managed to get into the dashboard once. Then it kept kicking me out to the login screen. I re-installed WP (all except for the wp-content folder) and it that is still not helping it any.

    I’m trying to revert it back to a different theme. Hopefully I’ll manage to get to that page sometime today.

    Hey!

    I’m striking out more than anything. I can barely get to the Dashboard. I tried to set the theme many times, but failed each time (it kicked me out to the login screen). I have deleted the advanced-cache file in the wp-content, but it didn’t help. 🙁 Any other tips? Should I try to get into the DB and set the theme there?

    Did you try to make changes from your hosting control panel? Try adding -old to the plugins folder and themes folder to revert to the default theme.

    If these do not produce any results, it is better to wipe of everything, reinstall WordPress and restore your site from the backup.

    Overloading and server configurations also cause problems in your Godaddy hosting account. So, seeking their support can also help. Also look at your error logs to see if there are any specific issues.

    I did change the plugin folders. I couldn’t revert the theme because I need access to the Dashboard don’t I?

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Incredibly slow–followed all advice’ is closed to new replies.