WordPress.org

Support

Support » How-To and Troubleshooting » incredbily slow website

incredbily slow website

  • blogreco
    Member

    @blogreco

    My website is incredibly slow. I deleted unused plugins, checked for vulnerabilities, and checked the cache options. Nothing seems to work. Any advice, suggestions?

Viewing 11 replies - 1 through 11 (of 11 total)
  • Mark Ratledge
    Forum Moderator

    @songdogtech

    Who is your web host?

    blogreco
    Member

    @blogreco

    dreamhost

    esmi
    Forum Moderator

    @esmi

    Have you tried:

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the Twenty Eleven theme to rule out any theme-specific problems.

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    [Topic tagged for Dreamhost’s attention.]

    BrianCanine
    Member

    @briancanine

    I had issues with a really slow website, also with dreamhost. I switched to Hostpapa – and now all is fine.

    Mika Epstein
    DreamHost Rep

    @ipstenu-dh

    blogreco, yes, your site is running a little sluggishly.

    I took a fast look at your site, and I can see you have a lot of plugins that could use updating. Also the cache plugin you’re using is Quick-Cache. We actually recommend using either WP Super Cache or W3 Total Cache. If you want to stick with Quick Cache, I would add in a Minification plugin (like http://wordpress.org/extend/plugins/wp-minify/ ) which will compress your CSS and make it load faster.

    The first thing I would do is get rid of some of your plugins. All the ones you’re not using, delete. The timthumb-vulnerability-scanner, for one, isn’t needed unless you’re using themes with TimThumb for most people. Also if you’re not using the importer plugins (blogger etc), turn them off and get rid of them.

    The other thing to keep in mind is your theme, Duotive. Because that’s hosted on ThemeForest, you may not get update notifications, so make sure you have their latest version.

    http://themeforest.net/item/duotive-three-complete-wordpress-template/

    Also @briancanine – I’m sorry to hear that.

    blogreco
    Member

    @blogreco

    Very good! Thanks Ipstenu-DH. That problem is resolved. Now i have another one. I didn’t purchase the template, the designer did it on my behalf. Any workarounds?

    Mika Epstein
    DreamHost Rep

    @ipstenu-dh

    Other than ‘pick a different’ theme? Not really.

    If someone bought the theme for you, they should have also left you with the ability to contact the theme (i.e. the license for that theme). If they didn’t, it’s difficult :/

    There are a lot of free themes here: http://wordpress.org/extend/themes/

    And even more commercial ones here: http://wordpress.org/extend/themes/commercial/

    All of those themes and companies are checked by WP to make sure their code is up to snuff, and their response time is beneficial for users.

    blogreco
    Member

    @blogreco

    Thanks Ipstenu-DH! So, here’s where i’m at. The website is still slow, I updated the plugins, removed the ones that were inactive, bought another license for Duotive Three. Changed the TimThumb.php to the most current version… and still no go. I am beginning to wonder if it is a hosting issue.

    Mika Epstein
    DreamHost Rep

    @ipstenu-dh

    It’s a little faster (my check runs a full 2 seconds faster, but at a 4.5 second page load, yeah, it’s still less than optimal). It’s not likely to be your host (or your server) since when I look at your other sites on the same hosting account, they’re fast (though they have nothing in them save a favicon). That tells me the server’s doing okay 🙂

    Looking into your error log, I see a lot of lines with “Premature end of script headers:” and looking at your panel, I see you’re using PHP 4. I’m honestly surprised your site is working at all (WP doesn’t support PHP 4 anymore, for what it’s worth).

    You should switch your domains to PHP 5 (I would do 5.3 FastCGI, but the 5.2 FastCGI is our default). You also may want to turn on CloudFlare (which I see you have on a subdomain, which is loading in 1.4 seconds).

    blogreco
    Member

    @blogreco

    Thanks Ipstenu-DH! I turned off CloudFlare and switched to 5.3FastCGI.
    I really appreciate all your help. I’m going to wait for the servers to catch up with the changes. I’m hoping that with all the changes I made this past weekend it will speed things up.

    Thanks again!

    Mika Epstein
    DreamHost Rep

    @ipstenu-dh

    You’re welcome! If that doesn’t help, open up a ticket with our support techs (and link to this thread so they know what’s gone on). I’ll keep an eye out for it just in case 🙂

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘incredbily slow website’ is closed to new replies.