Support » Fixing WordPress » increasing file size upload limit

  • Hello all,
    I’ve had relatively few issues with my site recently, but now I’m having another pretty major one. I’m not exactly sure what it was before, but I thought the file size upload limit was something like 16 mb when uploading directly either into the media library or uploading from the add media button on the posts page. Now, it seems to be down to just 2 mb. Come to think of it, this may have just happened in the last week, as the file I’m trying to upload this week is smaller than the one I posted last week. Anyway, how do I increase the file size upload limit so that I can upload audio again?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Moderator James Huff

    (@macmanx)

    Volunteer Moderator 🚀

    The maximum upload size is controlled at the server-level, not by WordPress. Here are three ways you can increase the upload limit:

    1. If you can edit or override the system php.ini file, increase the maximum file and post sizes. For example, upload_max_filesize = 100M ; and post_max_size = 100M ;

    2. If you cannot edit or override the system php.ini file, add php_value upload_max_filesize 100M and php_value post_max_size = 100M to your .htaccess file.

    3. If neither of these work, it’s time to ask your hosting provider to increase the maximum file and post sizes on your account. Keep in mind that most decent hosting providers allow this, and If your hosting provider won’t accommodate you, perhaps it’s time to find a new hosting provider.

    (in the above examples, the limit is set to 100MB)

    Ok, this seems to have resolved itself, but now I’m having another problem. While the file size limit has gone back to the previous 16 mb, now nothing comes up giving me the option to add media to my posts. I’ll see if I can post tomorrow, as it’s my posting day anyway, but trying to post tonight didn’t do anything. I clicked the add media link below where I enter the title of the post, and nothing happened. Usually, at the bottom of the page, it gives me the option to upload files, but that’s not appearing no matter how many times I press the link.

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator 🚀

    Try deactivating all plugins. If that resolves the issue, reactivate each one individually until you find the cause.

    If that does not resolve the issue, try switching to the Twenty Fourteen theme to rule-out a theme-specific issue (theme functions can interfere like plugins).

    Thanks. It seems as if I’m having very strange speratic issues with the site. I’m not sure if it’s my network or my computer or both, but I’ll try a few things.

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator 🚀

    You’re welcome!

    Please let us know how that goes. 🙂

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘increasing file size upload limit’ is closed to new replies.