Support » Fixing WordPress » Increase the import file size

  • Could you look to increasing the file size for the importing posts file. 2mb just isnt enough. I recently exported my posts and it was over 3mb in size. I think on older blogs with a lot of posts this is going to be common. and if like mine, there’s only the one poster, you can’t split it up.

    Thanks alot

Viewing 6 replies - 1 through 6 (of 6 total)
  • You can still break up that file into pieces if necessary.

    You might ask your host to increase PHP setting called max_upload_size as most hosts leave that at 2MB.

    Just modify php.ini with a text editor for yourself.

    Thread Starter Stormsguard

    (@stormsguard)

    I think your missunderstanding something. When i go into the import feature on the dashboard it says:

    Choose a WordPress WXR file to upload, then click Upload file and import.

    Choose a file from your computer: (Maximum size: 2MB)

    Thats what i want increased, 2mb isnt enough. I have 2 blogs, one with an exported files size of 2.7mb and the other with 3.2mb.

    If you can’t increase the max_upload_size by making a change to your php.ini file you have two choices:
    1. Ask your host if they can increase that setting
    2. Break the WXR file into pieces.

    Thread Starter Stormsguard

    (@stormsguard)

    How do i break it into pieces?

    Is there a tool i can use that does it automatically?

    I guess I’m off to ask my host to increase the size. I’m having enough issues with 2.5 that I want to do a fresh install, import my stuff, and port over, etc. The file I exported from my site is 17.6 MB in size!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Increase the import file size’ is closed to new replies.