Support » Plugin: Site Kit by Google - Analytics, Search Console, AdSense, Speed » Incorrect url shown in site kit plugin

Viewing 15 replies - 1 through 15 (of 30 total)
  • Plugin Support Renee Johnson

    (@reneesoffice)

    @wpschiemann thanks for your report!

    Could you let us know if you’re using a language plugin on the site?

    You could also share your Site Health Information which may further reveal what could be occurring.

    We’re currently working on this issue when the site is using subdirectory or the WPML plugin in particular. I’m curious if this is somewhat related.

    Thread Starter wpschiemann

    (@wpschiemann)

    Hey Renee, Yes, I used to use WPML plugin in combination with deepl translator on zoum.de and tried to offer some additional languages for foreigners and refugees but deactivated the plugins after noticing that automatic machine translation services like google translate or deepl are not yet good enough for a doctors or rather my wife’s and her partners website. Anyway, Site Kit Plugin is cool. Good job. Keep up the good work! Hope you can let me know here after you fixed the WPML plugin issue in combination with site Kit so only correct URLs are displayed in the future. I wish you health!

    Thread Starter wpschiemann

    (@wpschiemann)

    Below zoum website Health. Hope it helps and wont offer room for us getting hacked.

    If possible please delete this post after you got the information you Need.

    
    ### wp-core ###
    
    version: 5.4
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Berlin
    permalink: /%postname%/
    https_status: true
    user_registration: 0
    default_comment_status: closed
    multisite: false
    user_count: 8
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /www/htdocs/x/wordpress.zoum.de
    wordpress_size: 3,41 GB (3656733485 bytes)
    uploads_path: /www/htdocs/x/wordpress.zoum.de/wp-content/uploads
    uploads_size: 808,49 MB (847767704 bytes)
    themes_path: /www/htdocs/x/wordpress.zoum.de/wp-content/themes
    themes_size: 35,95 MB (37694409 bytes)
    plugins_path: /www/htdocs/x/wordpress.zoum.de/wp-content/plugins
    plugins_size: 129,75 MB (136055137 bytes)
    database_size: 58,27 MB (61101060 bytes)
    total_size: 4,41 GB (4739351795 bytes)
    
    ### wp-dropins (1) ###
    
    advanced-cache.php: true
    
    ### wp-active-theme ###
    
    name: Divi Child Theme (Divi-Child-Theme)
    version: 1.0.0
    author: Divi.world
    author_website: http://divi.world
    parent_theme: Divi (Divi)
    theme_features: custom-background, automatic-feed-links, post-thumbnails, menus, title-tag, post-formats, woocommerce, wc-product-gallery-zoom, wc-product-gallery-lightbox, wc-product-gallery-slider, customize-selective-refresh-widgets, editor-style, widgets
    theme_path: /www/htdocs/x/wordpress.zoum.de/wp-content/themes/Divi-Child-Theme
    
    ### wp-parent-theme ###
    
    name: Divi (Divi)
    version: 4.4.3
    author: Elegant Themes
    author_website: http://www.elegantthemes.com
    theme_path: /www/htdocs/x/wordpress.zoum.de/wp-content/themes/Divi
    
    ### wp-themes-inactive (1) ###
    
    Twenty Twenty: version: 1.2, author: WordPress-Team
    
    ### wp-plugins-active (32) ###
    
    Akismet Anti-Spam: version: 4.1.4, author: Automattic
    All In One SEO Pack: version: 3.4.2, author: All in One SEO Team
    Antispam Bee: version: 2.9.2, author: pluginkollektiv
    Better Search Replace: version: 1.3.3, author: Delicious Brains
    Colorlib Login Customizer: version: 1.2.95, author: Colorlib
    Cookie Notice: version: 1.3.1, author: dFactory
    Custom Facebook Feed Pro Personal: version: 3.11, author: Smash Balloon
    DeepL: version: 3.1, author: Neuronto
    Disable Comments: version: 1.10.2, author: Samir Shah
    Divi 404 Page Builder: version: 1.1.2, author: CODECRATER
    Google XML Sitemaps: version: 4.1.0, author: Arne Brachhold
    Insert Headers and Footers: version: 1.4.5, author: WPBeginner
    Instagram Feed Pro Personal: version: 5.5, author: Smash Balloon
    Limit Login Attempts Reloaded: version: 2.11.0, author: WPChef
    Opening Hours: version: 2.2.1, author: Jannik Portz
    Really Simple SSL: version: 3.3.1, author: Rogier Lankhorst, Mark Wolters
    Redirection: version: 4.7.1, author: John Godley
    Remove IP: version: 0.1, author: guido
    Shortcodes Ultimate: version: 5.8.1, author: Vladimir Anokhin
    Simple Custom CSS and JS: version: 3.30, author: SilkyPress.com
    Site Kit by Google: version: 1.7.0, author: Google
    SSL Insecure Content Fixer: version: 2.7.2, author: WebAware
    Statify: version: 1.6.3, author: pluginkollektiv
    Sucuri Security - Auditing, Malware Scanner and Hardening: version: 1.8.24, author: Sucuri Inc.
    TAO Schedule Update: version: 1.15, author: TAO Digital
    UpdraftPlus - Backup/Restore: version: 1.16.23, author: UpdraftPlus.Com, DavidAnderson
    VaultPress: version: 2.1.1, author: Automattic
    WP-Optimize - Clean, Compress, Cache: version: 3.0.19, author: David Anderson, Ruhani Rabin, Team Updraft
    WP DoNotTrack: version: 0.8.8, author: Frank Goossens (futtta)
    WPForms Lite: version: 1.5.9.5, author: WPForms
    WP Mail SMTP: version: 1.9.0, author: WPForms
    WP Meta and Date Remover: version: 1.7.7, author: Prasad Kirpekar
    
    ### wp-plugins-inactive (2) ###
    
    Divi Builder: version: 4.4.3, author: Elegant Themes
    Jetpack by WordPress.com: version: 8.4.2, author: Automattic
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1673
    imagemagick_version: ImageMagick 6.8.9-9 Q16 x86_64 2019-11-12 http://www.imagemagick.org
    imagick_limits: 
    	imagick::RESOURCETYPE_AREA: 31 GB
    	imagick::RESOURCETYPE_DISK: -1
    	imagick::RESOURCETYPE_FILE: 48750
    	imagick::RESOURCETYPE_MAP: 31 GB
    	imagick::RESOURCETYPE_MEMORY: 16 GB
    	imagick::RESOURCETYPE_THREAD: 8
    gd_version: bundled (2.1.0 compatible)
    ghostscript_version: 9.26
    
    ### wp-server ###
    
    server_architecture: Linux 4.4.0-177-generic x86_64
    httpd_software: Apache
    php_version: 7.3.11-nmm1 64bit
    php_sapi: fpm-fcgi
    max_input_variables: 10000
    time_limit: 30
    memory_limit: 256M
    max_input_time: 60
    upload_max_size: 200M
    php_post_max_size: 200M
    curl_version: 7.47.0 OpenSSL/1.0.2g
    suhosin: false
    imagick_availability: true
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.7.28-nmm1-log
    client_version: mysqlnd 5.0.12-dev - 20150407 - $Id: 7cc7cc96e675f6d72e5cf0f267f48e167c2abb23 $
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /www/htdocs/x/wordpress.zoum.de/wp-content
    WP_PLUGIN_DIR: /www/htdocs/x/wordpress.zoum.de/wp-content/plugins
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: true
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    mu-plugins: writable
    
    ### wpforms ###
    
    version: 1.5.9.5
    license: false
    lite: Jan 22, 2019 @ 10:28pm
    total_forms: undefined
    total_entries: undefined
    
    ### google-site-kit ###
    
    version: 1.7.0
    php_version: 7.3.11-nmm1
    wp_version: 5.4
    reference_url: https://zoum.de
    amp_mode: no
    site_status: connected-site
    user_status: authenticated
    active_modules: site-verification, search-console, analytics, pagespeed-insights
    required_scopes: 
    	openid: ✅
    	https://www.googleapis.com/auth/userinfo.profile: ✅
    	https://www.googleapis.com/auth/userinfo.email: ✅
    	https://www.googleapis.com/auth/siteverification: ✅
    	https://www.googleapis.com/auth/webmasters: ✅
    	https://www.googleapis.com/auth/analytics: ✅
    	https://www.googleapis.com/auth/analytics.readonly: ✅
    	https://www.googleapis.com/auth/analytics.manage.users: ✅
    	https://www.googleapis.com/auth/analytics.edit: ✅
    search_console_property: https://zoum.de/
    analytics_account_id: •••••
    analytics_property_id: UA-•••••••
    analytics_profile_id: •••••
    analytics_use_snippet: yes
    
    ### wp_mail_smtp ###
    
    version: 1.9.0
    license_key_type: lite
    debug: No debug notices found.
    
    

    @wpschiemann I have reviewed the site info you provided, and it contains no security-breaking information.
    By the way: you should never publish passwords and similar things here in the forum, not even “for 5 minutes”.

    Thread Starter wpschiemann

    (@wpschiemann)

    Hi @tobifjellner
    Can you please delete my above post like I asked? The health report and I are obviously too stupid to help fix bugs here. Thank you!

    Plugin Support James Osborne

    (@jamesosborne)

    @wpschiemann Can you check your Analytics account directly, outside of Site Kit. After doing so from the Admin tab you will find the “Default URL” option.

    Does this URL have your correct URL or is your domain also listed as a subfolder?

    Thread Starter wpschiemann

    (@wpschiemann)

    @jamesosborne
    nope, my analytics account looks normal. see…

    • This reply was modified 1 year, 3 months ago by wpschiemann.
    Plugin Support James Osborne

    (@jamesosborne)

    @wpschiemann Thanks for confirming. While we can certainly keep you updated on the WPML issue it might be worth also checking resetting Site Kit after temporarily deactivating some of your other plugins, in particular those that provide redirection or URL modifications.
    – Redirection
    – DeepL (which I believe integrate with your language plugins)

    If you’ve added any additional features using “Insert Headers and Footers” it might also be worth checking that this plugin also temporarily deactivated.

    Thread Starter wpschiemann

    (@wpschiemann)

    @jamesosborne
    sorry, dont have time at the moment to dig into this in detail further and disable and enable plugins. Doctors/practice website is in use and right now because of corona needed in order to not make any more people then really needed visit hopsitals. Also my wife might get angry with me if things dont work the way her teams expects. 😉

    It feels logical that the issue is sitekit & WPML related. WPML plugin combination are monsters and from what I saw the only plugin that really changed the structure of our website.Please let me know when the issue has been resolved.

    @tobifjellner
    Please delete the zoum website health report I posted!

    Thank you!

    Plugin Support James Osborne

    (@jamesosborne)

    @wpschiemann Completely understood, and we’ll certainly let you know once we have any updates on WPML compatibility.

    Thread Starter wpschiemann

    (@wpschiemann)

    @jamesosborne Hi, just wanted to let you know that this bug has not yet been fixed and wrong 404 urls are displayed after install of the latest version of site kit today.

    @tobifjellner HI, I ask you friendly two times to delete the above information. What do I have to do in order for you to comply?

    Thank you and have a nice weekend!

    Moderator Yui

    (@fierevere)

    ゆい

    @wpschiemann
    When a post is made and people contribute answers to an issue, that then becomes part of the community resource for others to benefit from. Deleting posts removes this added value. Forum topics will only be edited or deleted if they represent a valid legal, security, or safety concern.

    Your post contains nothing that can be considered as legal, security or safety concern. However, i have deleted your username from server’s path. Thats all we (moderators) can do. Please do not ask for more.

    Plugin Support James Osborne

    (@jamesosborne)

    @wpschiemann Sorry to hear your issue remains. Can you try deactivating and deleting Site Kit in full before reinstalling once more? Before going through the setup procedure with Site Kit please save your permalinks in order to rewrite access rules.

    If that fails please share an update copy of your Site Health information and we can troubleshoot further.

    Thread Starter wpschiemann

    (@wpschiemann)

    Hi @fierevere, hi @tobifjellner sad that you don’t comply to what I asked in a friendly manner. Especially since the information is no longer needed for site kit dev to solve the problem. @tobifjellner himself pointed out that it was a risk to paste a health report the way I did and your stubbornness behavior will certainly not help and encourage me to post anything here anymore. Who decides what is a security risk? You! If I have a different point of view do I have file a suit against this forum in order for you to comply?
    The information I posted is no longer needed and I ask one more time to please delete the health report, that from my point of view contains security related information that should not be posted here. Thank you!

    Thread Starter wpschiemann

    (@wpschiemann)

    @jamesosborne sorry James but under the circumstances I won’t be of any help for you. Anyway Site Kit Plugin is cool. It’s just obviously not yet fully compatible to the wpml translation plugin that changed the structure of our site.

Viewing 15 replies - 1 through 15 (of 30 total)
  • The topic ‘Incorrect url shown in site kit plugin’ is closed to new replies.