Support » Plugin: Simple Twitter Tweets » incorrect twitter link

  • Resolved asplespng


    When clicking on the link at the bottom of each tweet (time posted) I am led to someone else’s twitter page. Interestingly, the person’s twitter handle begins with the same 3 letters as mine. I resolved this issue by re-entering my twitter name in the widget settings and clicking save. However, the problem has re-appeared in my most recent tweets. Saving my settings again resolved the issue once more.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Just to clarify after some troubleshooting. Whenever a new tweet is posted, the links in all tweets are changed back to (e.g. if my twitter name is @abcdef). When i re-save the widget settings, the links are set correctly to (note @ symbol now present) until the next tweet is posted.

    Plugin Author Planet Interactive


    Hi asplespng,

    I’m not sure I understand you problem.

    Twitter URL links to accounts should be – their should not be an @ symbol in the URL.

    In the widget settings the Twitter Name should be entered without the @ symbol.

    If you are experiencing some other issue not resolved by the comment above, do let us know.

    Sorry I’ll try to explain. I removed the @ symbol now but still experience the same problem. The problem is that the twitter name is shortened.
    -I enter abcdefghij (not my actual name) in the twitter name field in the widget settings.
    -The url at the end of each tweet is shortened to (i.e. someone else’s twitter page)
    -the problem is sometimes temporarily resolved by manually clicking save in the widget settings 1 or more times, but reappears on the next import (after 5 minutes or whatever the widget is set to)
    Thank you for your help.

    Plugin Author Planet Interactive


    When refreshing the widget simply communicates with Twitter and pulls you most recent Tweets. The widget does not change your Twitter username.

    Also, just for clarity, their is no shortening occurring within the code for the user name.

    IMPORTANT: Please ensure you are using your Twitter username and not “your name” their should be no spaces or special characters (except _ ) in your username e.g. our Twitter Name is “Planet Interactive” but our username is iPlanetUK.

    Your username is the name you use to login at Twitter.

    Hope this helps and sorry if you know all this already.

    I came up with the same problem. Here is my solution:

    simple-twitter-tweets.php, after line 206, add this line
    $screen_name = $tweet->user->screen_name;

    Then in the same file, change the link on line 244 from this:
    <a href="<?php echo $name; ?>

    to this:
    <a href="<?php echo $screen_name; ?>

    It works fine for me!

    Plugin Author Planet Interactive


    Hi joshuacook13

    Thanks for the suggestion. Your line numbers don’t seem to match up with our code though we get the idea as this is in line with a previous release we had 😉

    Will roll out in next release with some of the other aspects we’re working on.

    If you want to send through your code for our diff feel free


    Plugin Author Planet Interactive


    Fixed in v1.3 thanks for the spot.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘incorrect twitter link’ is closed to new replies.