WordPress.org

Support

Support » Plugins and Hacks » incorrect title and URL

incorrect title and URL

  • Hi,

    when I try to share from the main (index) page, there is a bad title and URL being shared. Instead of taking both from the relevant post, as it does when you try to share from the single post page, it inserts generic site title and generic URL.

    In other words, whatever post sharing icon you click by any post, you always get just the same info to share.

    This is very incorrect. It should behave the same regardless of whether you click to share from the particular single post or from the index page with all posts.

    Could you fix it, please?

    http://wordpress.org/plugins/hupso-share-buttons-for-twitter-facebook-google/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author kasal

    @kasal

    I agree. Can you give me URL of your website so I can take a look?

    OK, you might have a look e.g. here:
    http://lidicka.luzanky.cz/

    I am using the shortcode in the WP loop:

    <?php if ( have_posts() ) : while ( have_posts() ) : the_post(); ?>
    <article class=”post post-aktuality group”>
    <header>


    if ( shortcode_exists( ‘hupso’ ) ) echo do_shortcode( ‘[hupso]’ ); else echo “<!– ERR: Hupso social plugin nenĂ­ k dispozici –>\n”;


    </div>
    </article> <!– //End of post–>

    Plugin Author kasal

    @kasal

    What if you do not use the shortcode, but go to plugin settings and show buttons on frontpage and on excerpts. Can you try this?

    Plugin Author kasal

    @kasal

    It seems that shortcodes are not working properly when they are used inside the loop.
    Please contact me here and I will send you an updated version that works properly.

    But they have to be in the loop, because they are post-related…
    I need (have to) to use the hupso plugin as shortcodes, because of the speciic layout…

    I have just sent you an e-mail, so we could try the patched version you are about to create. Thanks

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘incorrect title and URL’ is closed to new replies.