Support » Plugin: All In One WP Security & Firewall » Incorrect redirection to blocked users

  • Resolved nikolasgt

    (@nikolasgt)


    Hello! When I block someone user as a spammer, in the attempt of the blocked user to enter the site via facebook redirects the blocked user to the page that says “You must be logged in to access the administrator area.”
    It does not inform the user that they are blocked like those who make with classic Login to the site.

    i using the BuddyPress spam feature.
    Ι try clean cache and cookies from browser to deactive all plugins except All In One WP Security & buddypress and i have same problem, when i deactive All In One WP Security redirect works well.

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Contributor mbrsolution

    (@mbrsolution)

    Hi,

    in the attempt of the blocked user to enter the site via facebook redirects the blocked user to the page that says “You must be logged in to access the administrator area.”
    It does not inform the user that they are blocked like those who make with classic Login to the site.

    What are you using to set up the above redirect? Is it your theme, BuddyPress or a different plugin?

    i using the BuddyPress spam feature.

    Is this an addon for BuddyPress?

    when i deactive All In One WP Security redirect works well.

    So that means you have BuddPress and your theme running, is this correct?

    Regards

    • This reply was modified 1 year, 3 months ago by  mbrsolution.

    My theme is buddyapp
    This is https://themeforest.net/item/buddyapp-mobile-first-community-wordpress-theme/12494864

    It’s an «original» redirection buddyprress no addon.


    My theme running correct with buddypress this Theme is fully compatible with buddypress.

    Plugin Contributor mbrsolution

    (@mbrsolution)

    Do you have any features enabled under Login Lockdown? If you do what happens if you disable all the features under Login Lockdown? Does the redirect works?

    If the above does not apply to your settings, then disable all Firewall rules. Then carry out a test.

    Regards

    I tried it, I turned off all the options. Something has not changed. The problem existed. There is a problem not only when I turn it off All In One WP Security. When All In One WP security is active without any settings active, i have that problem.

    Plugin Contributor mbrsolution

    (@mbrsolution)

    Can you carry out one more test. Can you test one of WordPress default themes like Twenty Seventeen? Let me know what happens.

    Regards

    I can not, because the default wordpress themes they do not have the choice
    to login with facebook. Facebook login on buddyapp theme.

    Plugin Contributor mbrsolution

    (@mbrsolution)

    Hi, unfortunately I can’t test your theme and current set up in my site because it is a premium theme. I have submitted a message to the developers to investigate further your issue.

    Kind regards

    Plugin Author wpsolutions

    (@wpsolutions)

    Hi @nikolasgt
    Regarding the message you see:

    “You must be logged in to access the administrator area.”

    I double-checked the aiowps code for the above message and it appears that it is not coming from this plugin.
    Hence the behaviour you are seeing is probably being generated independently from either your theme or another plugin.

    It does not inform the user that they are blocked like those who make with classic Login to the site

    Are you referring to the message people see when using the login lockdown feature?

    Hello, all this messages its official wordress. Forgive me for my mistake, I use the Greek language and I did not do the translation correctly from the message “You must be logged in to access the administrator area.”
    Correct is “You must log in to access the admin area.”

    if i have all plugins deactive and i have active only my theme buddyapp with plugins buddypress and All In One WP Security and i have one user “spam” when this user go to login redirect go in page with message “You must log in to access the admin area.” if i just deactive only All In One WP Security and spam user go to login then redirection is correct and go in official wordpress login page and have message “ERROR: Your account has been marked as a spammer.”

    I marked users as a spammer from buddypress not from All In One WP Security.

    Plugin Author wpsolutions

    (@wpsolutions)

    Which feature from the “Brute Force” menu do you have active?

    Do you also have the login lockdown feature active?

    Login Lockdown is: Off
    Brute Force all is: Off

    I try to off all settings from All In One WP Security with “score” 0 .. and again have that problem.

    Plugin Author wpsolutions

    (@wpsolutions)

    Hi @nikolasgt,
    Can you try the adding following code to your theme’s functions.php file:

    add_action('aiowps_wp_loaded_tasks_end', 'remove_aiowps_loaded_actions');
    function remove_aiowps_loaded_actions($AIOWPSecurity_WP_Loaded_Tasks){
        remove_action( 'login_init', array( $AIOWPSecurity_WP_Loaded_Tasks, 'aiowps_login_init' ));
    
    }

    Let me know how that goes.

    You are the best! Its works well ! Thank you <3

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Incorrect redirection to blocked users’ is closed to new replies.