Support » Plugin: Force Regenerate Thumbnails » incorrect path even though file exists

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author Pedro Elsner

    (@pedro-elsner)

    Do you has this message error in all images?

    Yes, the error is produced for all images

    Plugin Author Pedro Elsner

    (@pedro-elsner)

    WP running on windows or linux?

    Linux server

    I tried opening up the permissions for the folders/files, uninstalling/reinstalling plugins, not sure what else to do.

    Plugin Author Pedro Elsner

    (@pedro-elsner)

    Right…

    This message error is produced by PHP function file_exists().
    Check your configuration server it is a start…

    Else, you can try to use this plugin (by Viper007Bond):
    http://wordpress.org/extend/plugins/regenerate-thumbnails/

    I get the same error when I use his plugin.

    Plugin Author Pedro Elsner

    (@pedro-elsner)

    So, I don’t have any idea to help you fix your problem =/

    companyjuice

    (@companyjuice)

    Hope this helps others that are experiencing this same issue…

    I had to strip the $fullsizepath in order for the plugin to find the existing file. This works with this Force Regenerate Thumbnails plugin as well as the Regenerate Thumbnails plugin.

    To fix, in the function ajax_process_image(), directly after this line:
    $fullsizepath = get_attached_file($image->ID);
    add this code:

    if (stripos($fullsizepath, 'C:\webroot\mydomain\wordpress\wp-content\uploads/') !== FALSE) {
    	$fullsizepath = str_ireplace('C:\webroot\mydomain\wordpress\wp-content\uploads/','',$fullsizepath);
    }

    Make sure that the string you are looking for matches the one in the failure message, of course.

    Hello
    I have the same problem
    Hi Pedro

    I have a problem

    form many image the plugin failed with this message

    “Penisolaverde” (ID 1058) failed to resize. The error message was: The originally uploaded image file cannot be found at /2013/04/Penisolaverde.jpg

    and the image exist: http://www.wikiplastic.com/wp-content/uploads//2013/04/Penisolaverde.jpg

    I have tryed adding this code

    if (stripos($fullsizepath, ‘C:\webroot\wikiplastic\wp-content\uploads/’) !== FALSE) {
    $fullsizepath = str_ireplace(‘C:\webroot\wikiplastic\wp-content\uploads/’,”,$fullsizepath);
    }

    but perhaps I do wrong with ‘C:\webroot\wikiplastic\ ???

    thank’s
    francesco

    Plugin Author Pedro Elsner

    (@pedro-elsner)

    @frengo70
    Try the new 1.7 version

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘incorrect path even though file exists’ is closed to new replies.