WordPress.org

Support

Support » How-To and Troubleshooting » Incorrect page display in website

Incorrect page display in website

  • I’ve used wordpress hosting service for my website chhav.com . I add page 2 , it appears there as well as in my homepage. Similarly if I add Page 3, it will be reflecting there as well as in home page. In short my home page will have all pages of my website. I tried changing page attributes like ‘order’,’parent page’ but of no avail. Please help.

    Thanks
    Rohan
    email: [Redacted – These are forums, please use them]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Go to your dashboard and see how many pages you have created. Is it that you are creating new posts instead of new pages?

    I’m creating pages not not new posts.. Currently it is reduced to only 2 pages since adding 4-5 pages will make homepage look very ugly. You can check it yourself (chhav.com). Same text and photos appearing on page 2 as well as home page.
    CURRENT PAGE ATTRIBUTES:

      Home Page

    Parent: No parent
    Template: Showcase template
    Order: 0

      Second Page:

    Parent: No parent
    Template: Showcase template
    Order:1

    I can also show screenshots of page attributes. I have tried changing different combinations of page attributes but of no avail.
    Please help.

    Sincere thanks
    Rohan

    You can create any number of pages without any problems. Try this: revert to Twenty Twelve theme with all plugins turned off and create a new page (say, a test page that you can delete or a contact page).

    Also see how you have set your site – that is for your blog and static pages.
    http://codex.wordpress.org/Creating_a_Static_Front_Page

    Hi Krishna

    I tried deactivating all plugins and was able to do so except one (Jetpack by WordPress.com) plugin. Even when I check this plugin and deactivate, it remains active.

    Then, I changed my theme from Twenty Eleven to Twenty Twelve and added page 3.

    Still it is showing same problem. Home page is now displaying all 3 pages. I changed page attributes of 3rd page but no effect.

    Regards
    Rohan

    From your dashboard, try to update WordPress (though it will show you have the latest version) and try after that.

    I think the problem is solved. This link helped:
    http://codex.wordpress.org/File:options-reading.png
    Thanks

    Welcome! 🙂

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Incorrect page display in website’ is closed to new replies.