Support » Fixing WordPress » Incorrect number of WordPress followers

  • Resolved settleinelpaso

    (@settleinelpaso)


    Hi,
    The problem I am facing is as follows.

    In the sidebar of my blog, I had been showing total subscribers for last couple of months. I have around 627 WordPress.com followers, 37 email subscribers, and 63 users in my blog. The total should be 627+63+37=727. It was correct for the past few months. Recently, the sidebar is showing the total as 2725. I am using the following code.

    <?php
    
    $result = count_users();
    $subs_count = get_transient('wpcom_subscribers_total');
    
    if (FALSE === $subs_count || 'failed' == $subs_count['status']) {
    	Jetpack:: load_xml_rpc_client();
    	
    	$xml = new Jetpack_IXR_Client(array('user_id' => JETPACK_MASTER_USER,));
    	
    	$xml->query('jetpack.fetchSubscriberCount');
    	
    	if ($xml->isError()) { // error
    		$subs_count = array(
    		'status' => 'failed',
    		'code' => $xml->getErrorCode(),
    		'message' => $xml->getErrorMessage(),
    		'value'=>(isset($subs_count['value']))?$subs_count['value'] : 0,
    		);
    	} else {
    	$subs_count = array(
    	'status' => 'success',
    	'value' => $xml->getResponse(),
    	);
    }
    
    set_transient('wpcom_subscribers_total', $subs_count, 3600); // cache
    }
    
    $active_subscribers = es_cls_dbquery::es_active_subscribers();
    
    echo "Join " . ($active_subscribers+$result['total_users']+$subs_count[value]) . " subscribers.";
    ?>

    I found that the Jetpack transient variable ‘wpcom_subscribers_total’ in my site is incorrect. Its value is 2625, where it is supposed to be 627. I used a plugin to view the values of the transients. I deleted the transient variable using the plugin many times but the same number appears back. I turned off caching (WP Super Cache) too with no effect.

    To resolve this issue I deactivated, deleted, and reinstalled jetpack but the subscriber-count is still the same and unexpectedly large. I also reinstalled WordPress on my site. No change either.

    Please let me know if you have any feedback on this problem. I am not sure if it is an issue related to WordPress.com, or Jetpack, or my WordPress installation.

    I appreciate your time and patience in reading this message.

    Have a wonderful week.

    Thank you.

    N

    • This topic was modified 3 months, 3 weeks ago by  Steve Stern. Reason: put code in backticks
    • This topic was modified 3 months, 3 weeks ago by  Jan Dembowski.

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.