WordPress.org

Forums

  1. Rob
    Member
    Posted 2 years ago #

    Hi, great lightweight plugin by the way. I have used it successfully on a couple of sites.

    But on one site I am creating the incorrect link is being shared. This doesn't happen on straightforward pages or single blog posts. Only on the main blog page, the home page where it lists portfolio CPTs, another CPT page of client logos.

    Basically where the page has multiple posts it's grabbing the final post title and link instead of the page as a whole. If I try and use wp_reset_postdata() it always takes the first post on the page instead. Very strange.

    Any ideas? I can DM/email you WP login details if you like. I'm using version 1.3.0. Thanks in advance.

    http://wordpress.org/extend/plugins/social-media-feather/

  2. Synved
    Member
    Plugin Author

    Posted 2 years ago #

    You can try enabling the new option "Share Full URL". This might break if you are displaying share buttons on archive pages, i.e. if the "Sharing Single Posts" is unchecked.

  3. Synved
    Member
    Plugin Author

    Posted 2 years ago #

    I pushed out a quick hotfix release that should fix this issue.

    By the way remember to uncheck the "Share Full URL" option.

  4. Rob
    Member
    Posted 2 years ago #

    Hi there, I've updated to version 1.3.1. I have always had Sharing Single Posts checked. I have tried it both with and without Share Full URL checked. But still all multi-post pages are trying to share the final post on the page rather than the whole page.

    Anything else I can try? Thanks.

  5. Synved
    Member
    Plugin Author

    Posted 2 years ago #

    That would make me think your theme is maybe running the_loop incorrectly, but that should break also the other links so I'm not sure.

    Can you pass a link to your site?

  6. Rob
    Member
    Posted 2 years ago #

    Hi there, do you have an email address I can send some login details to. The site is currently in development mode so you need to login to see it. Thanks.

  7. Synved
    Member
    Plugin Author

    Posted 2 years ago #

    You can submit it through our online contact form, but I'm not sure when I'll be able to get to it.

    It seems really odd though, if you enable share full URLs it should never use single post URLs... What theme are you using?

  8. Rob
    Member
    Posted 2 years ago #

    Ok, I'll do that now. Please let me know when you're able to take even a quick initial look.

    Thanks very much.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.