Support » Plugin: WP Mail SMTP by WPForms - The Most Popular SMTP and Email Log Plugin » Incorrect “From” settings. Google Workspace.

  • Resolved lorilself

    (@lorilself)


    Hello, our emails are sending with out problem, but I’m trying to change the “From” and am unable to figure out why it’s not working after hours of testing:

    1. I changed the plugin From Email and From Name settings from “A” to “B”.
    2. A and B are Google Workspace emails. B is an alias.
    3. I cannot get emails to send from B. They still show A. (Although, strangely, the very first test email after changing was partially correct – it was from B, but showed the reply-to as A. The Return Path is checked on. Then all subsequent tests were from A again.)

    The plugin is set up with “Other SMTP”. We have Elastic Email via Cloudways.

    fyi, I recently noticed that although the emails for “A” match exactly on the Workspace and plugin fields, the names are a bit different. Not sure if that’s important. I don’t know what other settings to check.

    Any suggestions for what to try next would be appreciated, thanks!

Viewing 6 replies - 1 through 6 (of 6 total)
  • Thread Starter lorilself

    (@lorilself)

    I forgot to mention that if I use the “force from” settings that it will send from “B”, but I can’t do that because I have a different “from” that I need to use for WooCommerce emails. thanks.

    Hi @lorilself,

    Thanks for reaching out. Could you please share if you’re using Google SMTP or Elastic mail SMTP settings? Usually, the ‘From Email’ can be set by other plugins as well if you don’t have the ‘Force From Email’ option checked. If the ‘Force From Email’ is checked and the other plugins such as WooCommerce have different ‘From Email’, then this email address will be set as Reply-To. This might be happening to the email you’ve described.

    You might also want to check out the Gmail mailer and make use of aliases.

    I hope this helps!

    Thread Starter lorilself

    (@lorilself)

    Hello and thanks for the reply. I am using the Elastic Email SMTP settings with the “Other SMTP” Mailer option.
    SMTP Host: smtp.elasticemail.com
    Encryption: TLS
    SMTP Port: 2525
    Authentication: on
    SMTP username and pw: both are entered.

    Emails are being sent, they just have the incorrect “From”.

    I’m not sure I understand what you’re saying. Since I don’t have the “Force From Email” checked, shouldn’t emails be sent from the one entered in the WP Mail SMTP settings? (Except for WooCommerce, which has it’s own “from” setup.) Is there something I’m missing?

    I don’t have any other plugins that use email settings. Only WooCommerce. Could there be a conflict here?

    Regarding your suggestion for using Gmail Mailer, from what I have read this would not be the best choice if you have more than 2,000 email contacts, correct? So that would not work for us.

    If you can think of anything else that I could check on that would allow emails to send using the plugin settings without using Force From Email, I would greatly appreciate it. Thanks!

    Hi @lorilself,

    Thanks for the details!

    Since I don’t have the “Force From Email” checked, shouldn’t emails be sent from the one entered in the WP Mail SMTP settings?

    Yes, that’s correct and that is the expected behaviour. However, if the emails (other than WooCommerce) are sent from an email address that is not set in WP Mail SMTP From Email field, there is likely another plugin utilizing the From Email. If you’re not aware of any other plugins, you might still want to check for conflict by deactivating other plugins one by one and the theme you’re using. ‘Force From Email’ is the only option that ensures all the emails will be sent from the ‘From Email’ in WP Mail SMTP.

    On a secondary note, for the WooCommerce emails, you might still need to use the same authenticated email address as a “From Email” or the email should be hosted on the same SMTP server. Using “From Email” as an unauthenticated sender hurts email deliverability.

    Would not be the best choice if you have more than 2,000 email contacts, correct?

    Yes, If you expect to send a high volume of emails, a Gmail mailer might not be a good fit.

    I hope this helps!

    Thread Starter lorilself

    (@lorilself)

    Thank you! I’ve finally figured it out after hours and hours of frustration, thanks to your suggestion to check on other conflicts.

    It turns out the culprit was a basic code snippet we installed when we first set up the site to override the default “from” address for WordPress emails. Apparently this was overriding the SMTP plugin sender settings – once I deactivated the snippet, everything worked smoothly. I wanted to include what I found here in case someone else runs into this same situation.

    Thanks again for the help!

    Hi @lorilself,

    You’re welcome, happy to help!

    Thank you for the update.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Incorrect “From” settings. Google Workspace.’ is closed to new replies.