Support » Fixing WordPress » Incorrect Calendar Widget Display

Viewing 15 replies - 1 through 15 (of 17 total)
  • Ok, I just deactivated all my plugins and the problem fixed itself. I then reactivated all my plugins again, and the problem still appears to be solved. Must have just been a glitch in the upgrade.

    I take it back. It’s fixed on index.php and page.php but not on single.php.

    yes I just noticed I have the same issue
    I thought I had just somehow missed it before, but after reading your posts I’m guessing it was the 2.9.1 that caused the issue for me too

    I currently have the same problem…not on the index page, just on the month archive pages (for example, http://www.spunkynomad.com/2009/11/). It was an issue for me before the update.

    Here’s a static image of the problem: http://www.spunkynomad.com/wp-content/uploads/2010/01/calendar_widget_problem.jpg

    Any help you can give will be greatly appreciated.

    I’ve got the same errors going on with WP’s built-in calendar. Please fix.

    Bump. Anyone wanna fix this??

    I reinstalled and the problem is gone.

    Has anyone else found a solution to this besides reinstalling? I am not sure I really want to go there.

    I tried a quick reinstall and it solved nothing for me. I did it through the dashboard. not sure if spunkynomad did something more in depth or not.

    I’m having the same problem. This really needs to be fixed. =/

    I even downgraded to 2.8.1 and im still having the problem. It’s making me want to shoot myself in the face.

    EDIT: I upgraded back to 2.9.2 and everything was still nice and broken. So I went into my dashboard to my general settings and changed the day of the week my calendar was set to begin on. I changed it from Monday to Sunday. This fixed the problem. I even changed it back to Sunday and it was still fixed.

    Hope that helps someone.

    I too am having the same problem with the standard WP calendar not working. When I create a new tab and bring up the blog the calendar appears correct. Once I move off the current month for the first time, all the dates are incorrect, even when I return to the current month.

    I tried the suggestions above – auto upgrade via tools, deactivate and reactivate plugins, change first day of the week and back.

    I looked at the link Frumph provided to ticket 11414 and can verify the calendar works properly when I change the timezone to Europe – London but the problem returns when I return my setting to America – Edmonton.

    I am unclear what the ‘latest “bleeding edge nightly”‘ that falterago applied (last comment in ticket) to fix his problem two weeks ago. Would not doing an automatic upgrade include this fix?

    Website is

    Please advise what fix is supposed to be added and where. Newbie working my way through learning the code.

    Much appreciated.

    I believe I fixed the problemm with the standard calendar widget.

    I changed the Timezone setting from America-Edmonton back to UTC-8 and the calendar appears to be working correctly.

    I do remember I originally had the Timezone set as UTC-8 and changed it to the Edmonton setting after one of the recent WP upgrades … can’t remember which version upgrade it was.

    cool, thanks for the info lewatson.
    I’m not sure what mine was set to but I changed it to denver (for mt time), it still wasn’t working right so I swapped it to UTC-7. looks like they’re lining up properly now. I thought I already had it on UTC-7, maybe it was on UTC-8 or something

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘Incorrect Calendar Widget Display’ is closed to new replies.