Support » Theme: Kadence » Incorrect Breadcrumbs on Product Page

  • I didn’t think this would be an issue with Kadence, but it appears to be.

    On one of my product pages (just one that I can see) the breadcrumbs are in correct. It is showing a completely wrong category. Like I said I didn’t think this would be from Kadence, but just to check I activated the Hello them on my test site and the breadcrumb was correctly, while when Kadence is activated the breadcrumb is incorrect.

    Here are some screenshots…

    https://ibb.co/8Dx8pQJ
    https://ibb.co/dJZxz2z

    Thoughts?

    Cheers

Viewing 7 replies - 1 through 7 (of 7 total)
  • Thread Starter streamworksaudio

    (@streamworksaudio)

    Just to add, if I set the breadcrumbs to use Rankmath (and set Rankmath to use Product Categories as the primary taxonomy) everything is fine there.

    karlalevelup

    (@karlalevelup)

    Hello,

    Thank you for reaching out to us and apologies for the delay!

    If you have multiple categories selected, the Kadence Theme breadcrumbs will consider the first category(alphabetically) as the primary one and print it on the breadcrumbs since we do not have a primary category functionality built-in.

    If you want to use the primary category instead, you can continue using the SEO plugin’s breadcrumb engine.

    Hope this clarifies and let us know if we can assist you further.

    Best Regards,
    Karla

    Thread Starter streamworksaudio

    (@streamworksaudio)

    Thanks Karla,

    I did think of that, so I removed all categories from the product and saved it – then I selected only one category and the breadcrumbs always showed the wrong category.

    Only thing I can think of is that there is some orphan meta data in the database somewhere that is confusing the theme. Or a bug 🙂

    It is working fine with Rankmath’s breadcrumbs though.

    Cheers

    karlalevelup

    (@karlalevelup)

    Hello,

    I tried the same case you specified but the only category is showing properly on the breadcrumbs of the product – https://share.getcloudapp.com/xQu686j9.

    If you have the latest version of the Kadence theme and WooCommerce plugin, use the Default breadcrumb engine, and test again, will the same issue happen on your end? It is possible that you also have some type of caching enabled which results in an incorrect category in the breadcrumb. Kindly try purging them as well after each change to see if the issue will be fixed.

    Kind Regards,
    Karla

    Thread Starter streamworksaudio

    (@streamworksaudio)

    Thanks Karla,

    I do not run any caching plugins on our server so it cannot be caused by caching. Unless there are some orphan records in the meta data table that could be giving Kadence problems. It is only happening for one product.

    Here is the default breadcrumbs with the said product:

    https://ibb.co/FK8TjtL

    Here is the same product using Rankmath’s breadcrumbs:

    https://ibb.co/jhTgzGq

    You can see that default breadcrumbs are not showing the final category.

    Cheers

    hannah

    (@hannahritner)

    Hi @streamworksaudio,
    Apologies for the delay! Have you tried clearing your browser cache? The fact that it is only happening for one product and we’re not able to replicate makes me think the issue falls on cache. Is that product set up differently than your others?

    Kindly,
    Hannah

    Thread Starter streamworksaudio

    (@streamworksaudio)

    When testing and coding I always work in Incognito with the inspector open and cache disabled.

    I haven’t looked at it in sometime as I am using Rankmath for breadcrumbs now.

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.