Support » Plugin: NinjaFirewall (WP Edition) - Advanced Security Plugin and Firewall » Incorrect auto_prepend path for LiteSpeed and OpenLiteSpeed?

  • Resolved luboslives

    (@luboslives)


    Hi, thanks for the great plugin.

    The instructions for manual config (and automatic config) of the WAF file for LiteSpeed and OpenLiteSpeed appear to be incorrect… but I’m not sure, it might be a permissions issue on my server.

    You suggest php_value auto_prepend_file "<rootdir>/wp-content/nfwlog/ninjafirewall.php" but there is no such file inside nfwlog.

    Is it
    a) supposed to be created by the plugin, or
    b) supposed to point to wp-content/plugins/ninjafirewall/ninjafirewall.php?

    Thanks for any clarification.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Thread Starter luboslives

    (@luboslives)

    I took a look at the install files and I see that it’s supposed to create that file inside nfwlog but it’s encountering a write access error. So it does seem like it’s a permissions issue that I’ve been struggling with on this server.

    Plugin Author nintechnet

    (@nintechnet)

    The file is created when you install NinjaFirewall. That looks like a permissions issue. The firewall must be able to create the /wp-content/nfwlog/ folder, where it will save several files.
    You can try to reinstall it (if you want to keep your current config, use the import/export option in the “Firewall Options” page).

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Incorrect auto_prepend path for LiteSpeed and OpenLiteSpeed?’ is closed to new replies.