Support » Fixing WordPress » Inconsistent File Permission error when attempting to update WordPress

  • Resolved thecrux

    (@thecrux)


    Hi,

    I have been unable to update my wordpress blog from 4.6.1 to 4.7 for the past couple hours. I get the following error:

    Downloading update from https://downloads.wordpress.org/release/wordpress-4.7-new-bundled.zip…
    Unpacking the update…
    The update cannot be installed because we will be unable to copy some files. This is usually due to inconsistent file permissions.: wp-admin/includes/update-core.php
    Installation Failed

    I see that this is not an uncommon problem just from searching the support forums but still haven’t been able to fix it myself. I used FileZilla to reset all my file permissions to ensure that all directories are at 755 and all files are at 644. This has not resolved the issue.

    My websited is hosted by BlueHost.

    Additional info:
    I was using WordPress just fine this afternoon while uploading some new media files. Half way through the process my image uploads began failing. About 5 uploaded, and the rest I couldn’t get to upload. I gave up on that and decided to update WordPress and some outdated plugins and that is when I began getting this error.

    When I tried to update my outdated plug ins I received the following error for every single plugin:
    “An error occurred while updating: “The package could not be installed. The package contains no files.'”

    I am assuming everything is related.

    Any assistance would be appreciated.

    • This topic was modified 3 years, 5 months ago by thecrux. Reason: add more info
Viewing 4 replies - 1 through 4 (of 4 total)
  • Moderator t-p

    (@t-p)

    – If your server does not allow auto updating, then try MANUALLY updating. Download a fresh copy of the WordPress .zip file to your computer, unzip it, and use that to copy up all files and folders EXCEPT the wp-config.php file and the /wp-content/ directory. You may need to delete the old wp-admin and wp-includes folders and files on your server before uploading the new ones. Please read the Manual Update directions first.
    Backup: If you haven’t already done, always backup everything (including your database) before doing any actions, just in case something really goes wrong. You can never have enough backups!

    Hi t-p, thanks for the info. I hadn’t thought to manually update because I’ve never done it before. I decided to manually update my plugins first and that worked well. In fact, I am wondering if the problem was not caused by a plugin issue, because after I had finished doing that everything began functioning correctly again in regards to uploads through the WP panel.

    Is it likely that a plugin could have caused this problem? If so, is there a way to determine which plugin it was? I don’t usually let so many plugins get out of date, but I was away the month of December so things got away from me.

    Moderator t-p

    (@t-p)

    Is it likely that a plugin could have caused this problem?

    Yes!

    For example, you can try deactivating ALL (yes all) plugins temporarily to see if this resolves the problem (plugin functions can interfere). If this works, re-activate them individually (one-by-one) to find the problematic plugin(s).

    OR, If you don’t have dashboard access, you can try – manually resetting the plugins folder by FTP/ SFTP (no Dashboard access required). If that resolves the issue, reactivate each one individually until you find the cause.

    HOWEVER, since you already have updated your plugins and they are working fine, now it’s too late to test which one was the bad apple.

    I had finished doing that everything began functioning correctly

    Glad to know it 🙂

    Having same issue here. I updated folder and file permissions and had same result. I’d prefer to not have people logging into the server to update the WordPress version each time would be much better through the WP-Admin.

    Is it safe for us to update the owner under the document root of the site?
    chown -R www-data:www-data .

    Once this was done it seems the update is working…just concerned about security.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Inconsistent File Permission error when attempting to update WordPress’ is closed to new replies.