Support » Plugin: Accept Stripe Payments » Incomplete translation (french)

  • Resolved alexis888

    (@alexis888)


    Hey, I have issues with having this plugin fully translated in french on the payment popup.
    All inputs’ labels related to customer’s address and credit card are still displayed in english rather than in french.

    These terms are not translated into french :
    Name
    Billing info
    Address
    City
    Country
    State
    Postcode
    Credit or debit card

    My wordpress langage setting is set to French, I did set “Popup Default Country” to french, I set “Stripe order langage” to french too (hence the credit card placeholder displaying in french, no problem with that).
    I also tried to instal “Country Autodetect” addon and set it to french to fix the problem but no luck.

    I’ve search for similar issues here and found these two topics :

    https://wordpress.org/support/topic/wp-plugins-stripe-payments-stable-fr-full-french-translation-for-stable/
    This one talking about a full french translation that has been released a year ago, however it doesn’t seem to work for me

    https://wordpress.org/support/topic/french-words-in-the-payment-popup/
    This one reporting a similar issue to mine but without any clear fix / solution

    I’ve also installed Loco translate to try to see if I could translate these terms myself but even though two french translation files are available for French, I can’t find the terms listed above in translation files.

    Eventually I found this post as an example showing that one of the of the terms I can’t find / translated is “waiting” since November 2019.

    Is there a fix for this ? I’m supposed to use this plugin on a client’s website but can’t use it as it is with mixed english / french words.

    Thanks !

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Contributor Alexander C.

    (@alexanderfoxc)

    Hi.

    Unfortunately, we can’t control WP’s translation editors, therefore we can’t make them approve pending translations.

    However, Loco Translate does the job. What you need to do is following:

    1. Go to Loco Translate -> Plugins, look for Stripe Payments and click it.

    2. Click French language. If you have 2 French languages displayed, select the one that has “Author” in “Folder” column.

    3. Click “Sync” button, then click “Save” button.

    4. Go to “Relocate” tab, select “Custom” option (languages/loco/plugins/stripe-payments-fr_FR.po) and click “Move files”.

    5. Done. Feel free to translate anything your want to French language via Loco Translate.

    Also make sure your WP language is set to French as well (which is already done it seems).

    Thread Starter alexis888

    (@alexis888)

    Hey, thanks for the fast answer again.

    You are just great !
    Two issues solved in less than a few hours on the same day. I’m going straight to the review section to give you 5 stars.

    Thanks a lot

    Plugin Contributor Alexander C.

    (@alexanderfoxc)

    Thank you for your positive review 🙂

    And for detailed reports as well.

    If this solved your issue with the translation, I’ll provide a link to this topic for others who are facing similar translation-related issues.

    We will also try to ping French editors to approve pending translations.

    Thread Starter alexis888

    (@alexis888)

    yes it did so go for it.
    Cheers

    Hey Alex!
    Wordpress forum didn’t tell me there was an answer!
    I came by myself to check

    Thank you for the very clear explanations.

    Indeed, there are 2 French languages displayed.
    I’ve chosen the right one you said
    But Sync failed.
    with a very long paragraph

    I repeated the process, always the sync failed.
    with this very long paragraph

    So I tried the other French language with “System” in Folder column and not “Author” But same : “Error sync”

    I notice there is this message above Sync Button :
    ” Debugging: The translations do not match the model. Please start synchronization to update from stripe-payments.pot ”

    So,
    I’ve gone ahead on yours instructions, with “Relocate” etc … it works!!!
    But “Name” and “Same billing and shipping info” are stil in english in the popup payment
    And Sync doesn’t want to work, so not able to save any sync

    Oh wait,
    I click on Edit template and I arrive on that stripe-payments.pot
    So I click on the Sync button on that page but same ‘Error sync” with a long paragraph
    I tried again by selecting only the “France” line, but same Error Sync

    • This reply was modified 10 months, 3 weeks ago by nourrirsafoi.
    • This reply was modified 10 months, 3 weeks ago by nourrirsafoi.
    • This reply was modified 10 months, 3 weeks ago by nourrirsafoi.
    • This reply was modified 10 months, 3 weeks ago by nourrirsafoi.
    • This reply was modified 10 months, 3 weeks ago by nourrirsafoi.
    • This reply was modified 10 months, 3 weeks ago by nourrirsafoi.
    • This reply was modified 10 months, 3 weeks ago by nourrirsafoi.
    • This reply was modified 10 months, 3 weeks ago by nourrirsafoi.
    • This reply was modified 10 months, 3 weeks ago by nourrirsafoi.

    In the Settings of the Loco Translate plugin, I found this in red color :

    Ajax test result:
    FAILED: {“data”:{“ping”:”\u039f\u039a \u2713″,”utf8″:”\u2713″}

    • This reply was modified 10 months, 3 weeks ago by nourrirsafoi.
    nourrirsafoi

    (@nourrirsafoi)

    OMG, Enfin!!!

    I’ve just resolved my issue.
    I desactivate WP Rocket plugin.

    This plugin was apparently the conflict.
    Oh dear… at last I found the issue.

    Everything is translated perfectly at last.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Incomplete translation (french)’ is closed to new replies.