Support » Plugin: WP Migrate DB » incomplete extract

  • Resolved Sliptonic


    I just upgraded to 0.4.4 and tried to migrate a site. I’ve used the plugin for several years and generally had very good luck. This time, the plugin produced a very small .sql file but threw no errors or warnings.

    I examined the sql file and it only creates only a subset of the tables:

    Any ideas?

Viewing 7 replies - 1 through 7 (of 7 total)
    • try again?
    • Uninstall the plugin and then reinstall it, and try again
    • use phpmyadmin to make the database-backup
    • use the tools of WP to create a database-backup

    like so:

    1. dashboard > tools > export > all content > download exportfile
    2. If required: confirm installation of export tool and run the export
    3. save the file to your desktop

    For future reference:
    Restoring a backup using the above database backup, goes ‘the other way around’:

    • dashboard > Tools > import > wordpress > select the correct back-up file > if required install and run import-plugin

    I’ve tried multiple times. I’ve uninstalled/reinstalled with same results.

    I’m trying to use this plugin because I need to migrate to another domain and the phpmyadmin export import won’t translate string serialization.

    I appreciate your response but I’m not sure how the other suggestions help since I need to change domains.

    Is there a way to get some debug information from the plugin about why it’s not exporting all the tables?

    1. Changing domains has no effect on the database = content.
    2. Use steps 1-3 to make a backup of the database.
    3. Import in the new database at the new domain
    4. FTP: make a backup of the old site
    5. FTP: Copy the FILES [including plugins, images etc] from the OLD to the new site; Overwrite!
    6. FTP: from the backup of the new site: upload / restore the ‘wp-config.php’ to the new site
    7. Check menus and settings of the new site
    8. Your new site should be OK

    I’ve done it many times.

    The wordpress export/import ignores theme overrides, widgets, and some other things so it won’t meet my needs.

    A phpmyadmin export produces serialization strings in the SQL so a global search and replace won’t work to change the domain unless the new domain is exactly the same length as the old domain.

    As I understand it, this is exactly the problem this plugin was written to solve. Are you telling me this plugin is obsolete or no longer necessary?

    If so, I don’t see it since I have no other way to migrate the complete site to a new domain with a different URL.

    I would not jump to that conclusion. I don’t know this plugin well enought to know if it’s up to the job you want it to do.

    I get the impression the previous version worked well, when you last used it.

    • Have you tried re-installing the previous version and sorting thing like that?
    • If the standard version won’t work, could the pro version help you out?

    If your theme is a bottleneck, why not

    1. first create a backup of the existing situation
    2. activate a standardtheme.
    3. Export the database
    4. Setup the new site in a standardtheme
    5. import the database
    6. Upload the backup of the original situation
    7. Restore the loose ends by hand

    Most unsatisfactory, true, but probably shorter than a complete rebuild from scratch.

    Plugin Author Brad Touesnard


    @sliptonic do you have WP_DEBUG set to true when you run the export? If not, that could be why you’re not seeing any errors.

    If you can send me your original database (not the migration) and also the migrated database, I should be able to figure out what has gone wrong.



    I faced the same issue.

    When you are exporting, simply select ‘Compress with GZIP’ rather than ‘Save as file to your computer’.

    Both actually produce the same sql file, just that when u select ‘Save as file to your computer’, it doesn’t get fully downloaded. Maybe some download or internet connection problem.


    Kanishk Dudeja

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘incomplete extract’ is closed to new replies.