WordPress.org

Forums

[resolved] Incomplete child theme CSS (5 posts)

  1. Distiple
    Member
    Posted 2 years ago #

    So Im creating a child theme for my new theme (have done this successfully before). I created a style.css file in my new child theme folder and added the import rule to import the parents stylesheet.

    When I activate the child theme, it seems only some of the CSS has been imported. The fonts are there, as are the colors, but many things are missing, dont load correctly, or are moved around.

    What am I doing wrong?

    I currently have the child theme active at http://friendsofjohns.com

    Thanks.

  2. esmi
    Forum Moderator
    Posted 2 years ago #

  3. Distiple
    Member
    Posted 2 years ago #

    Does this refer to the parent stylesheet? Could the problem be related to the fact that I now have 2 WP installations on 2 separate domains, but the second domain is an addon domain on my hosting?

    This adds a second folder under the public_html directory, so the themese folder for the second domain is under public_html/friendsofjohns.com/wp-content.

    I tried adding the full URL in the import rule (http://friendsofjohns.com/public_html/friendsofjohns.com/wp-content/themes/muse/style.css) but tstill no luck

  4. Distiple
    Member
    Posted 2 years ago #

    IM also not quite sure why the CSS Validator tool is referring to the SecondChildMuse folder. That was a test folder I added when I was unsuccessful wit the first, and I have since deleted it.

    Ive emptied the cache but it sill tries to find that file.

  5. Distiple
    Member
    Posted 2 years ago #

    Seems like the issue was indeed the addon domain. I ended up using this URL in the import rule: @import url("http://friendsofjohns.com/wp-content/themes/muse/style.css");

Topic Closed

This topic has been closed to new replies.

About this Topic