Support » Plugin: RSS Just Better » Incompatible with WordPress 4.7

  • This plugin is incompatible with WordPress 4.7 due to removal of wp-includes/class-feed.php

    Failed opening required ‘wp-includes/class-feed.php’ in wp-content/plugins/rss-just-better/RSS-just-better.php on line 1155

    It’s easily patched by changing the requires in wp-content/plugins/rss-just-better/RSS-just-better.php:

    
    function rssjb_List($feed, $filter, $num, $ltime, $list, $target, $pubdate, $pubtime, $dformat, $tformat, $pubauthor, $excerpt, $charex, $chartle, $sort, $cachefeed) {
        //WORDPRESS-1090 Patch to fix: RSS Just Better is incompatible with WordPress 4.7 - the if and all the require lines here
    	if ( ! class_exists( 'SimplePie', false ) ) {
    		require_once( ABSPATH . WPINC . '/class-simplepie.php' );
    	}
    
    	require_once( ABSPATH . WPINC . '/class-wp-feed-cache.php' );
    	require_once( ABSPATH . WPINC . '/class-wp-feed-cache-transient.php' );
    	require_once( ABSPATH . WPINC . '/class-wp-simplepie-file.php' );
    	require_once( ABSPATH . WPINC . '/class-wp-simplepie-sanitize-kses.php' );
    
    
Viewing 2 replies - 1 through 2 (of 2 total)
  • lighterdayz

    (@lighterdayzyahoocom)

    Thanks so much for posting the patch!

    I just found this. Thank you! There is a new problem with WP 4.7.4. Do you have a patch for this?
    [26-Apr-2017 12:36:36 UTC] PHP Notice: The called constructor method for WP_Widget in WP_RSSjb is <strong>deprecated</strong> since version 4.3.0! Use <pre>__construct()</pre> instead. in /home/baee_2012/dev.baeecorp.org/wp-includes/functions.php on line 3893

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Incompatible with WordPress 4.7’ is closed to new replies.