Support » Plugin: User Email Verification for WooCommerce » Incompatible with WooCommerce 4.9.0

  • solarian

    (@solarian)


    WC_Emails::email_header() and WC_Emails::email_footer() now take an additional argument. This causes a PHP fatal error on line 242 of includes/class-xlwuev-common.php and would cause a further error on line 244 (at the very least).

    This only applies when the setting “No, use WooCommerce native Email Header, Footer and styling options” is selected in the plugin settings, so a quick workaround is to use a custom email template instead.

    See this: https://github.com/woocommerce/woocommerce/pull/28204

Viewing 1 replies (of 1 total)
  • peter lipp

    (@peter-lipp)

    The faster way is to add the parameters into the code, you need to move the creation of the $email_abstract_object to before header and footer calls and add this parameter to the calls. Like

    ob_start();
    $email_abstract_object = new WC_Email();
    $mailer->email_header( $email_heading, $email_abstract_object );
    echo $email_body;
    $mailer->email_footer($email_abstract_object);

    Tested and works.

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.