Support » Plugin: Plugin Organizer » Incompatible with Woocommerce 3.2.1 and PayPal Plus for Woocommerce

  • Resolved newshop

    (@newshop)


    Hello,
    first of all: Your plugin is one of my alltime-favorites.

    Unfortunately there seems to be an incompatibility with “Woocommerce 3.2.1” and “PayPal Plus for Woocommerce”.

    The plugin “PayPal Plus for Woocommerce” adds an PayPal Plus-iframe as payment method to the checkout page. I noticed that since I updated Woocommerce from version 3.1.2 to version 3.2.1, the iframe disappeared. I had no idea that this has something to do with your plugin, as I deactived all plugins except Woocommerce and PayPal Plus for Woocommerce and the bug was still there.

    So I contacted the authors of “PayPal Plus for Woocommerce” because I thought that this incompatibility is caused by their plugin. They had a look and found out that the file PluginOrganizerMU.class.php is causing the problem. Deactivating Plugin Organizer did not help, but deleting PluginOrganizerMU.class.php file.

    When I downgrade woocommerce to version 3.1.2 its all working fine, but with version 3.2.1. the iframe does not show up anymore. So there is an incompatibiliy between Plugin Organizer, Woocommerce 3.2.1 and PayPal Plus for Woocommerce and I really hope that you can help me to fix that.

    Any help would be really appreciated.

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author Jeff Sterup

    (@foomagoo)

    I just tested using those 2 plugins with the plugin organizer MU plugin file in place and without it in place and there’s no difference. They both work. Check your plugin organizer setup and make sure you haven’t disabled either plugin anywhere on your site.

    Hi Jeff, thank you for your soon reply.

    Just to be sure we are talking about the same thing (because I thought you would have to apply for a paypal plus account and that would take a few days) – here is a screenshot of the iframe that disappears as soon as plugin organizer MU plugin file exists:
    http://www.bilder-upload.eu/show.php?file=1ea13f-1508175264.jpg
    Do you really see this iframe? I have checked my settings. It was all working fine with the same settings until I updated woocommerce to the latest version. Really dont know what to do now…

    Just noticed that the iframe comes back when I disable “Selective Plugin Loading”. But I need it to be enabled. Any idea what causes the iframe to disappear? It disappears also if I have all plugins enabled and also if I have the complete plugin organizer plugin disabled. It disappears as soon as the MU file exists, no matter if the plugin is active or not…this is so weird..

    • This reply was modified 8 months, 1 week ago by  newshop.

    [comment deleted, because wrong support forum, uups]

    Plugin Author Jeff Sterup

    (@foomagoo)

    I already have a paypal sandbox account so I didn’t need to apply for one. You have disabled one of the plugins somewhere on your site. Go to the plugin organizer settings page. Click the plugin search tab. Then select WooCommerce or Paypal Plus for WooCommerce in the dropdown and click the search button. That will search your database and tell you were you have disabled those plugins. Enable them on the pages in the results and try it again.

    Ok great, thank you. I got it, although the solution is strange:
    I had disabled PayPal Plus plugin on my static home page (www.mywebsite.com) because this is just a landing page and I needed this plugin only in the checkout. Anyway, enabling the plugin on the home page made it work on checkout page too. Dont understand why the home page does affect the checkout…?!

    Plugin Author Jeff Sterup

    (@foomagoo)

    It must be doing some kind of ajax hit to the homepage.

    I just wanted to add to this thread that the same thing happened to me.

    Although ON Globally, and ON on the Checkout page, my Stripe plugin was NOT showing, generating a ‘Sorry, it seems that there are no available payment methods for your state.’ message in the checkout form.

    But once I went in and also activated the Stripe plugin on the Home page (the one WP has set as ‘Front’) THEN everything worked again. Not sure why it needs to be that way, but I am just super happy that I found this thread and looked at that issue.

    Thanks newshop for your post and Jeff for all your work on this plugin.

    I’m getting the same behavior as majecdad on my WooCommerce site, but with the Authorize.net CIM plugin. If I had Selective Plugin Loading On, the VISA/MasterCard section on the WooCommerce checkout page disappeared. If I turned this Off, the section was available.

    Thanks to the post above, I discovered that I had disabled the Authorize.net plugin on the WordPress Page selected as my home page for the site. When I removed it from the disabled section, the problem went away.

    This is a recent development, so to speak, but I’m not sure if it is a Woo Plugin update or an update of this plugin. Regardless, this is a not-so-obvious issue as I believe most users would not expect a setting on the “home page” to impact the checkout page. I certainly didn’t think disabling something that is only available on the checkout page and in background routines would be impacted by the settings on the Page defined as my home page.

    My guess is that the endpoint that might be impacted by the home page setting is the /wc-ajax mechanism. I think that maybe when this is called on the checkout page for the available payment methods (normal behavior), the “home page” settings are used for this. SI tried to set up a Plugin Filter for this, but it didn’t seem to have an impact.

    I believe this was also causing some other issues with orders not being accepted in background routines and such. So it’s was a pretty major problem for us.

    Anyway…just wanted to chime in

    Plugin Author Jeff Sterup

    (@foomagoo)

    The payment processor might be doing a callback to your site. When it does it is hitting your homepage with arguments and the woocommerce plugin is deactivated there. That is common behavior for a payment processor. Check your setup to verify the callback url for your site and make sure you have Woocommerce and the other plugins you need enabled there.

    Well, in my debugging, there’s nothing in the request logs from Authorize.net at the point the checkout page loads. But your point about the homepage callback is what I was mentioning about the /?wc-ajax request. Its a request from my browser to our server root.

    I’m unwilling to turn off “Ignore URL Arguments”, so I’ll just be VERY careful on the home page.

    As a suggestion, this might be a good item to add to the docs or faq as there have already been three of us who have run into this in the last week..

    Thanks for your fast response. I gotta say this plugin makes a huge difference for my site due to the combination of plugins I require (bbPress, buddyPress, and Woo). I have some custom ajax calls and pages and the ability to turn off various plugins cut my response times from close to 1100ms at times down to 150ms.

    Thank you so much!

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Incompatible with Woocommerce 3.2.1 and PayPal Plus for Woocommerce’ is closed to new replies.