Support » Plugin: SQLite Integration » Incompatible with SlimStat Plguin

  • Resolved steadybright

    (@steadybright)



    Is there a workaround for this type of failure? I would like to use SlimStat with SQLite Integration. Please let me know. These are two examples (in HTML below) of many similar errors using SlimStat with SQLite integration:

    <html>
    <head>
    <title>nginx-error.log</title>
    </head>
    
    <body>
    2014/03/17 11:30:31 [error] 308#0: *2 FastCGI sent in stderr: "PHP message: WordPress database error <div style="clear:both"> </div><div class="queries" style="clear:both; margin_bottom:2px; border: red dotted thin;">Queries made or created this session were
    
    <ol>
    <li>Raw query:	SET @@session.time_zone = '+00:00'</li>
    <li>Rewritten: SELECT 1=1</li>
    <li>With Placeholders: SELECT 1=1</li>
    <li>Prepare: SELECT 1=1</li>
    <li>Executing: (no parameters)</li>
    </ol>
    </div><div style="clear:both; margin_bottom:2px; border: red dotted thin;" class="error_message" style="border-bottom:dotted blue thin;">Error occurred at line 157 in Function query.  Error message was: <h1>Unknown query type</h1><p>Sorry, we cannot determine the type of query that is requested.</p><p>The query is SET @@session.time_zone = '+00:00'</p> </div>
    <pre>#0  PDOEngine->get_error_message() called at [/nginx/http/worpress/wp-content/plugins/sqlite-integration/pdodb.class.php:171]
    #1  PDODB->query(SET @@session.time_zone = '+00:00') called at [/nginx/http/worpress/wp-content/plugins/wp-slims" while reading response header from upstream, client: 11.22.33.44, server: blog.example.com, request: "POST /wordpress/wp-admin/admin.php?page=wp-slim-view-3 HTTP/1.1", upstream: "fastcgi://127.0.0.1:9000", host: "blog.example.com", referrer: "https://blog.example.com/wordpress/wp-admin/admin.php?page=wp-slim-view-2"
    2014/03/17 11:30:35 [error] 308#0: *2 FastCGI sent in stderr: "PHP message: WordPress database error <div style="clear:both"> </div><div class="queries" style="clear:both; margin_bottom:2px; border: red dotted thin;">Queries made or created this session were
    <ol>
    <li>Raw query:	SET @@session.time_zone = '+00:00'</li>
    <li>Rewritten: SELECT 1=1</li>
    <li>With Placeholders: SELECT 1=1</li>
    <li>Prepare: SELECT 1=1</li>
    <li>Executing: (no parameters)</li>
    </ol>
    
    </div><div style="clear:both; margin_bottom:2px; border: red dotted thin;" class="error_message" style="border-bottom:dotted blue thin;">Error occurred at line 157 in Function query.  Error message was: <h1>Unknown query type</h1><p>Sorry, we cannot determine the type of query that is requested.</p><p>The query is SET @@session.time_zone = '+00:00'</p> </div></pre>
    <pre>#0  PDOEngine->get_error_message() called at [/nginx/http/worpress/wp-content/plugins/sqlite-integration/pdodb.class.php:171]
    #1  PDODB->query(SET @@session.time_zone = '+00:00') called at [/nginx/http/worpress/wp-content/plugins/wp-slims" while reading response header from upstream, client: 11.22.33.44, server: blog.example.com, request: "POST /wordpress/wp-admin/admin.php?page=wp-slim-view-6 HTTP/1.1", upstream: "fastcgi://127.0.0.1:9000", host: "blog.example.com", referrer: "https://blog.example.com/wordpress/wp-admin/admin.php?page=wp-slim-view-3"
    </body>
    </html>

    Thank you for your help. I think this is an excellent plugin!

    sb

Viewing 3 replies - 16 through 18 (of 18 total)
  • Hi camu,

    Thank you. I’ll check it out when you release it.

    Sincerely,

    steady

    Or contact us if you want to test the current beta.

    http://support.getused.to.it

    I’ve just had to disable WP SlimStat. The fixes you worked on which enabled both plugins to work together, have been undone by recent plugin updates. To be more specific, WP SlimStat tables populate normally, but the corresponding charts do not–the charts all show zero (0).

    Unfortunately, I’m not receiving any errors in the PHP nor nginx logs, so it’s difficault to know what’s gone wrong.

    I must keep SQLite Integration, because MySQL is too cumbersome (in resources), and SQLite does an amazing job. I’m very impressed!

    I realize problems like this are difficult to solve, and I appreciate your effort!

    steady

Viewing 3 replies - 16 through 18 (of 18 total)
  • The topic ‘Incompatible with SlimStat Plguin’ is closed to new replies.