Support » Plugin: WooCommerce POS » Incompatible with PHP 7

  • Jeasy

    (@jeasysehgal)


    Hi There,

    Love your plugin and can’t live without it. However our host, Bluehost upgraded the PHP to PHP 7 and seems your plugin came up sith some errors when we ran the PHP compatibility checker plugin.

    Below is the errors it picked up.

    wp-content/plugins/woocommerce-pos/includes/class-wc-pos-server.php
    ————————————————————————————————————————————-
    FOUND 4 ERRORS AFFECTING 4 LINES
    ————————————————————————————————————————————-
    73 | ERROR | Global variable ‘$HTTP_RAW_POST_DATA’ is deprecated since PHP 5.6 and removed since PHP 7.0 – use php://input instead.
    74 | ERROR | Global variable ‘$HTTP_RAW_POST_DATA’ is deprecated since PHP 5.6 and removed since PHP 7.0 – use php://input instead.
    75 | ERROR | Global variable ‘$HTTP_RAW_POST_DATA’ is deprecated since PHP 5.6 and removed since PHP 7.0 – use php://input instead.
    77 | ERROR | Global variable ‘$HTTP_RAW_POST_DATA’ is deprecated since PHP 5.6 and removed since PHP 7.0 – use php://input instead.
    ————————————————————————————————————————————-

    Thought I’d let you know for the next update. WOuld be great if you could update the plugin for PHP 7

    Cheers, Jeasy

  • The topic ‘Incompatible with PHP 7’ is closed to new replies.