WordPress.org

Support

Support » Plugins and Hacks » [Resolved] incompatible with newest YOP poll

[Resolved] incompatible with newest YOP poll

  • I do not know if still actual on newer WP versions, but I am unable to activate newest “YOP poll” while “Role scoper” plugin is active. PHP fatal:

    Fatal error: Cannot redeclare dump() (previously declared in …../wp-content/plugins/role-scoper/lib/debug_shell.php:36) in /var/www/cmsfinal/wp-content/plugins/yop-poll/inc/plugin-functions.php on line 170

    I will post this on Role scoper WP plugin support, too.

    http://wordpress.org/plugins/yop-poll/

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author YOP
    Participant

    @yourownprogrammer

    Hi crysman,

    Edit inc/plugin-functions.php, delete “dump” (approximately on line 165) function and save.

    Please let us know if you need more help.

    Regards,

    YOP Team

    Thanx, I can fix it myself, sure, but I’ve posted it here to let YOU fix the problem in general (because it is not crysman-only-related). You use “yop_poll_*“-like naming convention, so why not renaming it to “yop_poll_dump” ?

    That shall prevent any future compatibility issues of this kind.

    Plugin Author YOP
    Participant

    @yourownprogrammer

    Hey crysman,

    Thanks for letting us know. We used this function for debugging.
    We will soon release a new version that will include a fix for this issue.

    Best wishes,

    YOP Team

    Thanks a lot in the name of everyone affected. Happy hollidays! 😉 Closing this thread…

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Resolved] incompatible with newest YOP poll’ is closed to new replies.