Support » Plugin: Cloudflare » Incompatible with most current php

  • My site needs to update the php and before doing that I checked the plugin PHP Compatibility Checker, the cloudflare plugin is the only one that has the latest php version errors, follows the error:

    ARCHIVE: /cloudflare/cloudflare-plugin-backend/src/SecurityUtil.php
    ————————————————– ————————————————– ————————————————–
    2 ERRORS FOUND 1 LINE FOUND
    ————————————————– ————————————————– ————————————————–
    16 ERROR The mcrypt_create_iv () function has been deprecated since PHP 7.1 and removed since PHP 7.2; Use random_bytes () or OpenSSL
    16 ERROR The ‘mcrypt’ extension has been deprecated since PHP 7.1 and removed since PHP 7.2; Use openssl (preferred) or pecl / mcrypt once available
    ————————————————– ————————————————– ————————————————–

    ARCHIVE: /cloudflare/vendor/symfony/yaml/Parser.php
    ————————————————– ————————————————– ———-
    0 ERRORS AND 1 WARNING FOUND 1 LINE FOUND
    ————————————————– ————————————————– ———-
    72 ATTENTION The INI directive ‘mbstring.func_overload’ has been deprecated since PHP 7.2
    ————————————————– ————————————————– ———-

    ARCHIVE: /cloudflare/vendor/symfony/yaml/Inline.php
    ————————————————– ————————————————– ———-
    0 ERRORS AND 1 WARNING FOUND 1 LINE FOUND
    ————————————————– ————————————————– ———-
    55 ATTENTION The INI directive ‘mbstring.func_overload’ has been deprecated since PHP 7.2
    ————————————————– ————————————————– ———-
    How to solve this case?

Viewing 3 replies - 1 through 3 (of 3 total)
  • I have abandoned this plug-in and now use Cloudflare Flexible SSL instead. Running php 7.4.3

    Richard

    • This reply was modified 1 year, 4 months ago by LordDunvegan.
    Thread Starter diogocardoso2010

    (@diogocardoso2010)

    Thanks for the answer @lorddunvegan, I was wondering if it has the same functions?

    @diogocardoso2010 It certainly gets rid of the SSL looping issue and combined with WP Cloudflare Super Page Cache Plugin appears to make a good (better?) job of things.

    I have also now started to use LetsEncrypt certificates in combination with CloudFlare’s flexible SSL and set SSL to Full.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Incompatible with most current php’ is closed to new replies.