Support » Plugin: Yoast SEO » Incompatible with Classic Editor/Disable Gutenberg

  • Resolved vaszeit

    (@vaszeit)


    I (rather stupidly) upgraded my WP to 5.0 only to be shocked by the new Gutenberg editor. I then found and installed Classic Editor and Disable Gutenberg plugins, hoping my problems would be immediately solved but no, they weren’t.

    After some playing around, I discovered that Yoast plugin prevents Classic Editor and Disable Gutenberg from working properly. When Yoast is enabled, I get a blank editor window, even though there is content there. I also can’t add anything to that window as it’s completely unresponsive/disabled. When Yoast is disabled, the plugins work fine.

    I’ve found a few other people have this very same issue, though some have not linked it to Yoast. How can this be solved? Turns out, these two plugins (Yoast and Classic Editor) I can’t live without. Thanks in advance!

Viewing 6 replies - 1 through 6 (of 6 total)
  • Hi,

    For your info (if it may help somebody),

    After updating to WordPress 5.0 I had a problem with Gutenberg (not loading the content of previous posts and could not use it to create new content) and classic editor (was not able to see the content in view mode, but OK in text mode).

    I’ve tried with another theme. Same problem.
    I desactivated all the others plugins. Same problem.

    Then on my side it was not a problem of incompatibility between plugins or theme.

    But finally I solved the problem by adding a single line in wp-config.php

    See at https://www.wpbeginner.com/wp-tutorials/how-to-fix-white-text-and-missing-buttons-in-wordpress-visual-editor/ where I found the solution.

    Add the following line at the very top after the php opening tag in wp-config.php :
    define(‘CONCATENATE_SCRIPTS’, false);

    Now both Gutenberg and classic editor behave normally.

    About SEO plugin, I’m using “The SEO Framework”. No problem at the present time with this plugin + Gutenberg.

    Thread Starter vaszeit

    (@vaszeit)

    Thank you, but this tweak did not work for me. Same behavior – both plugins work fine with Yoast deactivated and don’t when Yoast is activated.

    Plugin Support devnihil

    (@devnihil)

    @vaszeit This issue can be caused by another plugin (besides Yoast/classic editor) or theme conflicting with the metabox. Can you try and gather as much information for us as possible? Please perform the following:
    1. Make sure the issue doesn’t persist when Yoast SEO is disabled.
    2. Check for conflicts.
    3. Check for JavaScript errors with your console.
    If you find any JavaScript errors related to Yoast SEO or if there is a conflict with a plugin or a theme, you can create a new GitHub issue for our developers. Please report the issue to a third party developer as well.
    If you didn’t find any conflicts or errors, we think the issue is specific to your site. We’d need to investigate further but are unable to do so on these forums. You can purchase Yoast SEO Premium and receive our Premium email support and we can help you further.

    Thread Starter vaszeit

    (@vaszeit)

    Hi, thank you for assisting with this. I disabled all plugins as part of my troubleshooting so I am quite sure it’s not another plugin. But it’s quite possible that it’s my theme. I will do more investigation on my end and report here.

    Plugin Support Michael Tina

    (@mikes41720)

    If you switch to a default theme such as TwentySeventeen, does the Yoast SEO meta box then load as expected? If so, then it must mean that the conflict with Yoast SEO is with your theme.

    Plugin Support Michael Tina

    (@mikes41720)

    No further response. Setting to closed.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Incompatible with Classic Editor/Disable Gutenberg’ is closed to new replies.