Support » Plugin: IP Geo Block » incompatible with Awesome Support plugin

  • Resolved baldzius

    (@baldzius)


    Hi,

    Your plugin is really great, nicely done.
    I noticed that I can’t get it working with Awesome support plugin https://wordpress.org/plugins/awesome-support/ . Eventually to get it working I had to disable “Prevent malicious file upload”. Checked mime types and files extensions and all were fine but still was causing me issues.
    Mentioning just in case if somebody has same issue. Not sure if this can be fixed.

    Thanks,
    Aldas

Viewing 13 replies - 16 through 28 (of 28 total)
  • Plugin Author tokkonopapa

    (@tokkonopapa)

    After I configure the capability of my “Sample Role” just same as yours (by deleting read_private_sunshine_galleries and edit_others_posts), I tested:

    but doesn’t if there is no attachment.

    It worked.

    Reply to no attachment

    How about your before apply_filter: and after apply_filter:? I think you saw both were empty. But after apply_filter: should be 1.

    The most possible cause would be that your code sneppet in your theme’s functions.php were not executed. So I’d propose another solution.

    You can find a file drop-in-sample.php in /wp-content/plugins/ip-geo-block/wp-content/ip-geo-api/. Please copy and paste it into your
    Geolocation API library folder named ip-geo-api which is typically placed under the /wp-content/. Then rename the file to drop-in.php and put the same code snippet as in this thread at the bottom of the file.

    Finally, Geolocation API library folder should be like this:

    /wp-content/ip-geo-api/
    ├── drop-in.php <== THIS ONE!!
    ├── index.php
    ├── ip2location
    │   ├── IP2LOCATION-LITE-DB1.BIN
    │   ├── IP2LOCATION-LITE-DB1.IPV6.BIN
    │   ├── IP2Location.php
    │   ├── bcmath.php
    │   └── class-ip2location.php
    └── maxmind
        ├── GeoIP.dat
        ├── GeoIPv6.dat
        ├── LICENSE
        ├── class-maxmind.php
        ├── geoip.inc
        └── geoipcity.inc

    Just in case, please comment out the code (copied to drop-in.php) in your theme’s functions.php.

    I believe this would solve the issue!

    Thread Starter baldzius

    (@baldzius)

    sorry but it’s exactly the same issue, can’t reply to ticket without attachment.
    If you don’t mind we could do a zoom session where you will see for yourself and I can give you a remote access to my system. If you could give me your preferred London time I will gladly do it. Today I will be at home from 5pm-7pm London time.
    Thanks for all your help. I really appreciate your work. Please let me know if that suits you. I think it will be much better and faster than through this ticket if you really want to find the reason.
    All the best. Aldas

    Plugin Author tokkonopapa

    (@tokkonopapa)

    Hi Aldas,

    I hope you to send me an email to tokkonopapa at yahoo.com

    Thanks.

    Plugin Author tokkonopapa

    (@tokkonopapa)

    Hi Aldas,

    I have to offer you an apology for my mistake!

    … can’t reply to ticket without attachment.

    I had reproduced the issue and fixed another bug. Please update IPGB once more to 3.0.3.5 in this thread.

    And also you need the codes in functions.php or drop-in.php. The document about the filter hook ip-geo-block-upload-capability may help you.

    In near future, I’ll release a new version 3.0.4. So please keep using 3.0.3.5.

    I deeply thank you for taking your time and giving me a chance to fix the issue!!

    Thread Starter baldzius

    (@baldzius)

    you are amazing. It’s working, yay!!!!!!!!!!
    I updated code and added snippet back to functions.php
    Just last question – how it’s going to be in the future releases? Will they still need custom code or you are planning on fully integrating inside your code? Just to be sure.
    Thanks again for all your help. It’s always nice to meet people who are so passionate and dedicated to their work. If I had a job position I would hire you in an instance. Extremely well done.
    Thank you again.
    All the best.

    Plugin Author tokkonopapa

    (@tokkonopapa)

    Grad to hear that!

    Just last question – how it’s going to be in the future releases? Will they still need custom code or you are planning on fully integrating inside your code?

    Sorry but I have no plan to embed the snippet into my plugin’s core because other uploader may have different slug of capability. So please keep it in your functions.php.

    Thanks again for all your help.

    My pleasure!

    Again, thanks for your time.

    Thread Starter baldzius

    (@baldzius)

    Understood. Do you think it’s worth engaging AS devs as they might make changes which could become compatible with this plugin out of the box? Do you think they can fix it with their code change or is it lost cause?

    Plugin Author tokkonopapa

    (@tokkonopapa)

    Hi Aldas,

    Thank you for your nice rating ★★★★★!!

    Well, I don’t think, as a developer, that AS can change their capability attach_files to upload_files. Although once I wrote:

    It should be upload_files which you can find in Roles and Capabilities.

    in this thread, I was wrong.

    When you assign “Support User (wpas_user)” to your guest as a role, AS can change the capability because AS can use its original role.

    But in your case, you assign “Subscriber” to your guest. Originally in WP core, a “Subscriber” doesn’t have the capability for upload_files. So you have to give it to “Subscriber”. There’s no immediate security issue at this moment. But I don’t know in the future 😛

    “Options minimum, Extendability maximum” is my basic design concept. But the number of options in IPGB becomes to increase practically. So I’m wondering if IPGB had better to have an option that can specify some additional capability for user’s convenience.

    Anyway for now, I’d appreciate your patience.

    By the way, the snippet in your functions.php can be a little bit simpler. Please replace yours to new one in http://www.ipgeoblock.com/codex/ip-geo-block-upload-capability.html .

    Thanks for asking!

    Thread Starter baldzius

    (@baldzius)

    Understood. Tested your new snippet and all works fine. Thanks again for all your help.
    I will hire you if I ever need a php developer 🙂

    Plugin Author tokkonopapa

    (@tokkonopapa)

    I will hire you if I ever need a php developer 🙂

    It’s such an honor to be told that!

    By the way, could you test a new version 3.0.4 if you have enough time?

    How to:

    1. Deactivate IPGB.
    2. Download the above zip file and unzip it.
    3. Upload “ip-geo-block” folder in unzipped folder to your “/wp-content/plugins/”. You can over write existing one in your server. Please do not upload other files such as test, “.gitignore” and so on.
    4. Activate IPGB again.

    You can test this feature:

    After you configure like the above, you can remove the code snippet in your functions.php.

    Thanks again for your cooperation!

    Thread Starter baldzius

    (@baldzius)

    works like a charm! This is amazing. Thanks a lot on improving this. This solution is so clean.

    Thread Starter baldzius

    (@baldzius)

    Sorry I spoke too soon. Apparently now I can’t upload new plugins as Administrator. Could you please double check.

    Thread Starter baldzius

    (@baldzius)

    Sorry. I am an idiot. Please ignore my previous update 🙂

Viewing 13 replies - 16 through 28 (of 28 total)
  • The topic ‘incompatible with Awesome Support plugin’ is closed to new replies.