WordPress.org

Ready to get started?Download WordPress

Forums

Use Google Libraries
[resolved] Incompatible with 3.6? (7 posts)

  1. belg4mit
    Member
    Posted 1 year ago #

    Although your site lists the plugin as compatible through 3.6b3, I am running 3.6 and

    wp_enqueue_script('jquery-ui-tabs')

    Does not load any JavaScript when the plugin is enabled. When disabled, the local copy is referenced in the HTML as

    <script type='text/javascript' src='https://example.com/wp-includes/js/jquery/ui/jquery.ui.tabs.min.js?ver=1.10.3'></script>

    http://wordpress.org/plugins/use-google-libraries/

  2. Jason Penney
    Member
    Plugin Author

    Posted 1 year ago #

    Sorry, I was away on vacation. I'll look into this as soon as I can.

  3. belg4mit
    Member
    Posted 1 year ago #

    Nevermind, I needed to update WP-Minify settings to exclude new jQuery version, or better yet use a shorter exclusion pattern to future-proof it.

  4. Jason Penney
    Member
    Plugin Author

    Posted 1 year ago #

    If you let me know the pattern you're using maybe I could add it to the README.

  5. belg4mit
    Member
    Posted 1 year ago #

    The future-proofed strong to add to "JavaScript files to exclude from minify (line delimited)." is:
    //ajax.googleapis.com/ajax/libs/jqueryui/

  6. belg4mit
    Member
    Posted 1 year ago #

    Actually, even more generic is
    //ajax.googleapis.com/
    for both JS and CSS exclusion. This is necessary because WP-Minify does not recognize URIs beginning with // as remote.

  7. Jason Penney
    Member
    Plugin Author

    Posted 1 year ago #

    I was going to suggest that. It's probably similar to the issue with Better WordPress Minify mentioned here.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic