Support » Plugin: All In One WP Security & Firewall » Incompatible PHP V7.1 Issue

  • Hi,

    My hosting has upgraded to PHP Version 7.1, but this plugin breaks some of it’s feature with it. Example the Who is lookup module stops working.

    When I switch back to PHP Version 7.0 the plugin works fine.

    Please help me to solve the issue, as I need to upgrade my php version to latest for other themes and plugins, but I can’t compromise with the security. So I am got pinned here. Please help me out of this. Thank you.

    [ Signature deleted ]

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Contributor mbrsolution

    (@mbrsolution)

    Hi, the plugin works with PHP version 7.1. The only feature in the plugin that is giving warnings is the Who Is Lookup. The developers are already aware of this. They are already looking into improving this feature.

    The plugin is secured and works with PHP 7.1.

    Kind regards

    • This reply was modified 4 years, 2 months ago by mbrsolution.
    Thread Starter svayam

    (@svayam)

    Thank you very much about the update. the should I activate PHP 7.1 or shall wait for the next update?

    Kind regards,

    Plugin Contributor mbrsolution

    (@mbrsolution)

    Hi, you can update your server to PHP 7.1. Just don’t use Who Is Lookup for now.

    Kind regards

    Thread Starter svayam

    (@svayam)

    Hello,

    I am about to install my site tomorrow (03-11-2017) freshly from the scratch as it got HACKED a few days ago. I am not blaming anyone, but it’s very relevant in the present scenario.

    1) I just want to know, that how long it may take for “All In One WP Security & Firewall” to release the new update? As everyone is well aware that already WordPress is v4.8.3 and many of us is using PHP 7.1. For which it should be a major update, specially dealing with the security issue.

    2) If it is possible to introduce the renaming of the “wp-admin.php”, like iThemes, Shield Security, etc. already has. Like we can change the login slug for “wp-login.php, I think this is very much necessary for AIOWS and should be implemented as soon as possible.

    3) restricting the number of 404 error generation and blocking the specific IP within a given time, i.e. 20 times in 5 mins. this is also an inevitable feature.

    As we love AIOWS so thought I can ask for this. we don’t want to move out from this great plugin 🙂 Please try to implement and update these features, then no one will be stronger than All In One WP Security & Firewall in the market as a complete free security solution.

    If you please let me/us know the probable date of the update release, then it will be very helpful to plan accordingly. Thank you. 🙂

    Kind regards,

    Plugin Contributor wpsolutions

    (@wpsolutions)

    Hi @svayam,
    I’m not sure I fully understand the points you listed in your last reply. Please see my responses below.

    1) I just want to know, that how long it may take for “All In One WP Security & Firewall” to release the new update? As everyone is well aware that already WordPress is v4.8.3 and many of us is using PHP 7.1. For which it should be a major update, specially dealing with the security issue.

    The plugin is essentially compatible with with PHP7.x. For now only some of the whois feature library files may show a PHP compabitibility warning but since that feature is not essential to the security of your site simply don’t use it for now.
    I am currently working on various improvements and fixes and a new release should be up in a few weeks hopefully.

    2) If it is possible to introduce the renaming of the “wp-admin.php”, like iThemes, Shield Security, etc. already has. Like we can change the login slug for “wp-login.php, I think this is very much necessary for AIOWS and should be implemented as soon as possible.

    The aiowps plugin already has this feature. Look in the brute force menu.

    3) restricting the number of 404 error generation and blocking the specific IP within a given time, i.e. 20 times in 5 mins. this is also an inevitable feature.

    Once again this is already available in the Firewall >> 404 Detection page.

    Thread Starter svayam

    (@svayam)

    Hello,

    I was really expecting that AIOWSF v4.3.0, will be compatible with PHP 7.1.11 But unfortunately the WHOIS Look feature is still not working as usual.

    Within a few hours from now the WP v4.9 is about roll out also by the end of this month / 1st week of December PHP 7.2 will be released.

    Is it really that hard to make this fine security plugin to be compatible and implementable with all this VERY BASIC technologies?

    Am I asking too much?

    Thanks & regards,

    Plugin Contributor mbrsolution

    (@mbrsolution)

    @svayam, are you still receiving the same warning messages in your log files? What IP address have you tested so far?

    I tested a few IP address in my test environment running PHP 7.1.11 and it worked for a few IP addresses.

    Regards

    • This reply was modified 4 years, 2 months ago by mbrsolution.
    Thread Starter svayam

    (@svayam)

    Hello,

    Here is some IPs which I have blacklisted earlier but not working when I searched through the WHOIS Lookup tool.

    46.161.9.56
    46.161.9.61
    79.209.217.101
    83.24.216.108

    And here is the some of IPs which are working!

    162.158.165.26
    162.158.111.35
    172.68.144.197
    134.19.210.239

    It’s very confusing and unusual thing that I am facing. Some is working while others are not. Can’t understand the logic behind this. either the tool work for all otherwise dose not work for any.

    While in PHP 7.0 all of them are working. Thanks for your kind concern. Please see to this issue. Please do not mind as I feel, that I was a bit rude to you yesterday after the update. I owe you an apology personally. Thanks once again.

    Kind regards,

    Plugin Contributor mbrsolution

    (@mbrsolution)

    Thank you for reporting back and providing some sample IP addresses. I have submitted a message to the developers to investigate further this issue.

    Kind regards

    Thread Starter svayam

    (@svayam)

    Thanks for your concern. I am looking for the solution for this issue..

    Kind regards

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Incompatible PHP V7.1 Issue’ is closed to new replies.