Support » Plugin: Geolocation IP Detection » Incompatibility with Wordfence and Maxmind with version 4.2.0

  • Resolved Charles A. Kush III


    Your latest 4.2.0 update broke WordPress sites with Wordfence and Maxmind again. Please roll back and always test with Wordfence and Maxmind before release. See below:

    Geolocation IP Detection: Error: Old Maxmind Libraries detected.
    Appearently, there is another plugin installed that also uses the Maxmind libraries, but their version of these libraries is outdated.
    These files have been found to be loaded from another plugin: /wp-content/plugins/wordfence/vendor/geoip2/geoip2/src/Database/Reader.php , /wp-content/plugins/wordfence/vendor/maxmind-db/reader/src/MaxMind/Db/Reader.php
    Please disable that plugin, update that plugin or use a different data source in Geolocation IP Detection. Until then, the lookup for Maxmind sources is disabled.
Viewing 9 replies - 1 through 9 (of 9 total)
  • gunther12


    Same issue here.



    Same for me – I dowgnraded to 4.1.0 and everything is working again. Before I tried deleting the database and updating it again, but that did not change anything.



    Same. Also part of the error message was not clear to me: “Until then, the lookup for Maxmind sources is disabled”. Do you mean in general (e.g. also for WooCommerce) or just for WordFence? I didn’t want to take chances so had to roll back to my backup.

    Plugin Author Benjamin Pick


    The problem is that there are at least 20 wordpress plugins that are using Maxmind libraries, often using different versions, some are compatible with each other, some not. I tried to automate this detection with 4.2.0 but obviously, the detection was to strict – as both files from wordfence are loaded, it works again. In 4.2.1 (that is about to be released), I left the admin notice, but removed the “automatic deactivation” of the lookup from the GeoIP plugin.

    The problem is also whether it works or not depends also on the plugion loading order, which depends somehow on which plugin you activated first. So it’s hard for me to test every possibility. Thank you for your bug reports.



    Thanks for your answer! But sorry – as a user I just want both plugins to work. And I don’t want any warning in my backend that I cannot do anything about. So what’s the solution? Everything seems to be working with 4.1.
    Also I still don’t get the problem – why can’t different plugins use different libraries?

    Plugin Author Benjamin Pick


    Yes I understand, this is not user-friendly, and I would love to find a solution that is easier.

    I wrote up the technical background to the problem here:

    The issue is tricky because every plugin potentially influences the code of the other plugins, and in this case this happens often, as this library is installed via composer and composer is not meant to be used seperately in every plugin. Typo3 is solving this by using a installation-wide composer set up (so that composer would complain at install time that two different version of the same Maxmind library are required by 2 different plugins).



    I’m quoting from your other post:

    Maybe I should make these notices less visible (trying to show them only in case of error, and on a “troubleshooting” page)?

    I’d suggest to do that, otherwise I think many users (including me) will stay with 4.1.0 to avoid the cluttering of the backend with that warning which is also not a long term solution because we won’t get updates then.

    BTW: It’s ok to show warnings, but only if there is a feasible solution that the user can work on to get rid of it. In this case, there isn’t one.

    • This reply was modified 1 year ago by gunther12.
    Alain Aubry


    Same issue here. I went back 4.1, it seems to be working fine!

    Plugin Author Benjamin Pick


    In 4.2.2, it works the same as in 4.1, it just shows a warning message on the plugin page. You can dismiss that warning once you’ve read it.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Incompatibility with Wordfence and Maxmind with version 4.2.0’ is closed to new replies.