Support » Plugin: Fish and Ships - WooCommerce shipping table rate. The most flexible shipping method » Incompatibility with Woocommerce Multicurrency

  • Resolved crokis31

    (@crokis31)


    Hi!

    First thank you for your amazing work on this plugin! I recently experienced an issue with Woocommerce Multicurrency plugin. When I’m trying to add a Simple Product to cart, I have the following error (that I don’t have for variable ones!).

    —–
    Fatal error: Uncaught Error: Class ‘WOOMC\MultiCurrency\Rate\Storage’ not found in …/wp-content/plugins/fish-and-ships/fish-and-ships.php:856

    Stack trace: #0 …/wp-content/plugins/fish-and-ships/includes/settings-form-fns.php(760): Fish_n_Ships->currency_abstraction(‘main-currency’, 60)
    #1 …/wp-includes/class-wp-hook.php(287): wc_fns_calculate_cost_rule_fn(0, Array, Array, Array, Object(WC_Fish_n_Ships))
    #2 …/wp-includes/plugin.php(212): WP_Hook->apply_filters(0, Array)
    #3 …/wp-content/plugins/fish-and-ships/includes/shipping-class.php(480): apply_filters(‘wc_fns_calculat…’, 0, Array, Array, Array, Object(WC_Fish_n_Ships))
    #4 …/wp-content/plugins/woocommerce/includes/abstracts/abstract-wc-shipping-method.php(233): WC_Fish_n_Ships->calculate_shipping(Array)
    #5 …/wp-content/plugins/woocommerce/includes/class-wc-shipping.php(345): WC_Shipping_Method->get_rates_for_package(Array)
    #6 …/wp-content/plu in /var/www/lachance/wp-content/plugins/fish-and-ships/fish-and-ships.php on line 856
    —-

    After having a look to the source code, the “\WOOMC\MultiCurrency\Rate\Storage()” class seems to doesn’t exist anymore in the Woocommerce Multicurrency plugin…

    Thank you in advance for your help!

    • This topic was modified 8 months ago by crokis31.
Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author wpcentrics

    (@wpcentrics)

    Hi @crokis31.

    Yes, seems there is a change on class namespaces of WooCommerce MC plugin, from his changelog (https://dzv365zjfbd8v.cloudfront.net/changelogs/woocommerce-multicurrency/changelog.txt):

    2020-02-02 – version 2.0.0
    * Backward-incompatible: namespace \WOOMC\MultiCurrency renamed to \WOOMC – update your code if you use the WOOMC\API class.

    Fortunately, seems a minor change, I think in a few hours we can solve the bug and publish a compatibility update.

    I will back here when it is done.

    Regards,
    Carles Martin
    wp-centrics support team

    Thread Starter crokis31

    (@crokis31)

    Thank you for that!

    Regards

    Plugin Author wpcentrics

    (@wpcentrics)

    Hi, @crokis31, just updated Fish and Ships to v1.2.2, please, update and confirm it works for you

    Regards,
    Carles.

    Thread Starter crokis31

    (@crokis31)

    Hello,

    Everything is working well now, thank you for the fast support!

    Regards

    Plugin Author wpcentrics

    (@wpcentrics)

    Glad to help!

    Cheers,
    Carles Martin
    wp-centrics support team

    PD: If you like Fish and Ships, you’ll help us a lot by writing a review about 😉

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Incompatibility with Woocommerce Multicurrency’ is closed to new replies.