Support » Plugin: BackWPup - WordPress Backup Plugin » Incompatibility with new version of W3 total cache V 0.9.7.5 CDN CloudFront

  • First of all, thank you for this plugin which we consider very helpful.

    We use was CloudFront CDN with w3 total cache.
    Yesterday, we installed the update of W3 total cache. V 0.9.7.5

    Since then, there is no way to connect to CloudFront and upload files to our cdn.
    When we disable BackWup, W3 total cache CDN connects are works normally.

    Are you aware of this matter ?
    Do you have a workaround ?

    Thank you

    Yannis

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Support duongcuong96

    (@duongcuong96)

    Hi @medalkan
    so could you try to activate the plugin after you have done setup W3 total cache with CloudFront CDN? is that helps?
    Also, please give me some screenshots or the error log file of the issue so I can have a look.
    Thank you!

    Hello,

    Unfortunately, there is no way. I had to deactivate BackWup.
    The answer from the W3 total cache support is the following:
    ————
    We tried to limit the number of requests when w3tc loads the AWS library and it happens only when interaction with AWS is required. If you do the same, and will not load it always – potentially both products will be able to co-exist.

    Another option is to force both projects to use the same AWS library code.
    You should include AWS separately, and force W3TC not to load own copy setting
    define(‘W3TC_SKIPLIB_AWS’, true);

    W3 Total Cache is compatible with AWS SDK version 3 and may use it.
    Another project using AWS library should do the same.

    This other plugin seems loads AWS library always, even while it’s not used, so conflict is unavoidable. you should contact plugin authors about it.
    the potential solution now is to disable other plugin and enable it for backup processes only.
    ————-
    ERROR LOGS ARE AS FOLLOWS:

    mod_fcgid: stderr: PHP Fatal error: Uncaught TypeError: Argument 1 passed to Aws\\Common\\Client\\AbstractClient::__construct() must be an instance of Aws\\Common\\Credentials\\CredentialsInterface, array given, called in /var/www/vhosts/medalkan.gr/httpdocs/wp-content/plugins/w3-total-cache/CdnEngine_CloudFront.php on line 40 and defined in /var/www/vhosts/medalkan.gr/httpdocs/wp-content/plugins/backwpup/vendor/aws/aws-sdk-php/src/Aws/Common/Client/AbstractClient.php:73, referer: https://www.medalkan.gr/wp-admin/admin.php?page=w3tc_cdn

    mod_fcgid: stderr: Stack trace:, referer: https://www.medalkan.gr/wp-admin/admin.php?page=w3tc_cdn

    mod_fcgid: stderr: #0 /var/www/vhosts/medalkan.gr/httpdocs/wp-content/plugins/w3-total-cache/CdnEngine_CloudFront.php(40): Aws\\Common\\Client\\AbstractClient->__construct(Array), referer: https://www.medalkan.gr/wp-admin/admin.php?page=w3tc_cdn

    mod_fcgid: stderr: #1 /var/www/vhosts/medalkan.gr/httpdocs/wp-content/plugins/w3-total-cache/CdnEngine_CloudFront.php(159): W3TC\\CdnEngine_CloudFront->_init(), referer: https://www.medalkan.gr/wp-admin/admin.php?page=w3tc_cdn

    mod_fcgid: stderr: #2 /var/www/vhosts/medalkan.gr/httpdocs/wp-content/plugins/w3-total-cache/Cdn_AdminActions.php(427): W3TC\\CdnEngine_CloudFront->test(NULL), referer: https://www.medalkan.gr/wp-admin/admin.php?page=w3tc_cdn

    mod_fcgid: stderr: #3 /var/www/vhosts/medalkan.gr/httpdocs/wp-content/plugins/w3-total-cache/Root_AdminActions.php(25): W3TC\\Cdn_AdminActions->w3tc_cdn_test(), referer: https://www.medalkan.gr/wp-admin/admin.php?page=w3tc_cdn

    mod_fcgid: stderr: # in /var/www/vhosts/medalkan.gr/httpdocs/wp-content/plugins/backwpup/vendor/aws/aws-sdk-php/src/Aws/Common/Client/AbstractClient.php on line 73, referer: https://www.medalkan.gr/wp-admin/admin.php?page=w3tc_cdn
    ———-
    This happens only when backWup is activated an we try to access cloudfrontvia w3 total cache

    Thank you for your support

    Yannis

    I also receive this mail from wordpress version 5.2.1

    Error Details
    =============
    An error of type E_ERROR was caused in line 73 of the file /var/www/vhosts/medalkan.gr/httpdocs/wp-content/plugins/backwpup/vendor/aws/aws-sdk-php/src/Aws/Common/Client/AbstractClient.php. Error message: Uncaught TypeError: Argument 1 passed to Aws\Common\Client\AbstractClient::__construct() must be an instance of Aws\Common\Credentials\CredentialsInterface, array given, called in /var/www/vhosts/medalkan.gr/httpdocs/wp-content/plugins/w3-total-cache/CdnEngine_CloudFront.php on line 40 and defined in /var/www/vhosts/medalkan.gr/httpdocs/wp-content/plugins/backwpup/vendor/aws/aws-sdk-php/src/Aws/Common/Client/AbstractClient.php:73
    Stack trace:
    #0 /var/www/vhosts/medalkan.gr/httpdocs/wp-content/plugins/w3-total-cache/CdnEngine_CloudFront.php(40): Aws\Common\Client\AbstractClient->__construct(Array)
    #1 /var/www/vhosts/medalkan.gr/httpdocs/wp-content/plugins/w3-total-cache/CdnEngine_CloudFront.php(159): W3TC\CdnEngine_CloudFront->_init()
    #2 /var/www/vhosts/medalkan.gr/httpdocs/wp-content/plugins/w3-total-cache/Cdn_AdminActions.php(427): W3TC\CdnEngine_CloudFront->test(NULL)
    #3 /var/www/vhosts/medalkan.gr/httpdocs/wp-content/plugins/w3-total-cache/Root_AdminActions.php(25): W3TC\Cdn_AdminActions->w3tc_cdn_test()
    #

    Thank you

    Yannis

    Plugin Support duongcuong96

    (@duongcuong96)

    Hi @medalkan
    I forwarded this issue to our devs, will back to when I have something new!
    Thank you very much for the detailed debug log! That would really helpful for us!

    FYI, I am having this same exact issue with BackWPup and W3. I look forward to seeing a fix.

    Also, please note I tried adding a filter function to backwpup_register_destination to remove the S3 key and it still didn’t help because it looks like composer autolaods all the files. I was also unable to update composer easily because no composer.json file appears to be included in the plugin.

    For what it’s worth, thanks for this thread. I am having the exact same issue. The only way I was able to purge Cloudfront CDN cache was by disabling BackWPup.

    Looking forward to an update to fix this issue.

    @medalkan Is there any news on this situation? Cheers.

    Nothing new.
    BackWup still disabled

    Same issue here. As a workaround, configure w3 total cache not to load the AWS library by including the following line in the wp-config.php file. Maybe you can consider adding a similar config option to backwpup and something in the documentation to inform users of this issue? Thanks! 🙂

    define(‘W3TC_SKIPLIB_AWS’, true);

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.