Support » Plugin: Responsive Gallery Grid » Incompatibility new RGG and the plugin Autoptimize

  • Resolved getiem

    (@getiem)


    I use the plugin Autoptimize to efficiently optimize my css and js from all elements on my website, including interface plugins. The old RGG was compatible, as most other plugins do, but the new version breaks.
    https://wordpress.org/plugins/autoptimize/

    Symptoms:
    When autoptimize and RGG are activated, the whole gallery is 0x0 pixels height x width
    – WPversion: 4.9.2
    – RGG version: 2.1.2
    –settings: link to image, image size medium, image link full, row heigth 400
    – Autoptimize version 2.3.2
    — settings: optimze html, optimize JS on, optimize js in html off!

    Workarounds now:
    Autoptimize setting: optimize js in html on!
    or
    Autoptimize settings: exclude following js files: main.js

    Problem is within the reference of the rgg_params
    rgg_params is defined in the html and is used in the js files.
    When the JS is, and the “JS in html” is not optimized/aggregated, the reference is gone.

    Maybe you can contact the developer of Autoptimize, Frank Goosens, https://profiles.wordpress.org/futtta to fix the little problem. As you are both living in the Antwerp region in Belgium, it should not be difficult 😉

    Cheers

    Gerben from the Netherlands.

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Well, not forcing JS in head would also fix things @getiem

    Groetjes uit regio Gent! 😉

    frank

    Well, thanks Frank @optimizingmatters,
    Sorry, Gent and Antwerp are just one region right 😉 haha like the Randstad is here…

    Not forcing in the head is fixing stuff now. Thanks for pointing out. That setting was on when debugging on an other plugin, but removed that one, so that is now a usable fix for me!

    Fixes another millisecond slowlyness too.. 😉
    Google Pagespeed A en Yslow B! Only comment on Gtmetrix is on the image dynamic size, but that is due to my choice to use RGG.

    • This reply was modified 2 years, 5 months ago by getiem. Reason: Solved
    • This reply was modified 2 years, 5 months ago by getiem.
    • This reply was modified 2 years, 5 months ago by getiem.

    Sorry, Gent and Antwerp are just one region right

    Gentenaren would not agree with that bold statement 😉

    Not forcing in the head is fixing stuff now.

    it is the default setting and makes sense from a perf. point of view, as the JS gets loaded as late as possible that way.

    fijn weekend!
    frank

    Thanks @optimizingmatters Frank,

    Glad you did adoption of autoptimize. Been using that plugin since the first developer published early days on wordpress.org

    Fijn Weekend!

    Plugin Author Jules Colle

    (@jules-colle)

    Glad it’s fixed! Thanks for jumping in @optimizingmatters! And I kind of agree that Gent and Antwerp are the same region. Antwerp is a suburb of Gent after all, but it is a fact that we are not too proud of it 🙂

    • This reply was modified 2 years, 5 months ago by Jules Colle.
    • This reply was modified 2 years, 5 months ago by Jules Colle.

    Thanks @jules-colle

    Bought you a pro version.
    Frank @optimizingmatters, you do not like donations or pro version, so a very big thanks
    (and a belgium beer) for you.

    Antwerp is a suburb of Gent after all

    well, Lokeren (where I live now) is a suburb of Gent, that’s for sure!

    you do not like donations or pro version,

    you can always buy me a Kiva gift-card to help me help others who need it more then I do 🙂

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Incompatibility new RGG and the plugin Autoptimize’ is closed to new replies.