Support » Plugin: WooCommerce » Incompatibility between WooCommerce Core and WooCommerce Subscriptions

  • Resolved chewventure

    (@chewventure)


    I am in the process of migrating my site from one host to another.

    Everything has gone smoothly except I am seeing the following error message plastered all over the site and within the WordPress Admin panel too:

    Warning: Declaration of WC_Product_Variable_Subscription::get_available_variations() should be compatible with WC_Product_Variable::get_available_variations($return = 'array')

    When I look at the status of WooCommerce Subscriptions it says that version has not been tested with WooCommerce Core.

    Both WooCommerce Core and WooCommerce Subscription plugins are on the latest version.

    Why is this message appearing and how can I fix it?

    Thank you

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Thread Starter chewventure

    (@chewventure)

    Ok, so I’ve rolled back my PHP version to 7.1.33 and the warning has disappeared.

    I’m guessing this is an integration issue between the plugins that WooCommerce needs to fix?

    Plugin Support EastOfWest a11n

    (@eastofwest)

    Hi there,

    WooCommerce Subscriptions is a premium extension sold on WooCommerce.com, and as such you’re able to get support for it there.

    To do so, log in to your WooCommerce.com account, and then follow this link:
    https://woocommerce.com/my-account/create-a-ticket/

    Select WooCommerce Subscriptions from the I need help with list and add the details of your enquiry there.

    In light of the above, I’ll mark this thread as closed.

    Thread Starter chewventure

    (@chewventure)

    @eastofwest – I’m working for a client that does not have access to the log-in details for WooCommerce and is not on good relationship with the original developer, thus this is our only support channel.

    Please don’t close this as we need to understand why we have to use an older, insecure version of php to have WooCommerce Core and WooCommerce Subscription play nicely together.

    Plugin Support EastOfWest a11n

    (@eastofwest)

    I’ve checked the latest version of WooCommerce Subscriptions (3.0.9) with the latest version of WooCommerce (4.6.1) on a sandbox site running PHP 7.4.12.

    It was not possible to recreate the error you reported.

    We’d love to look into your particular scenario but, for this extension, are only able to do so via WooCommerce.com. Please refer to our Support Policy for more info:
    https://woocommerce.com/support-policy/

    Thread Starter chewventure

    (@chewventure)

    Hmm, that’s odd. Thanks for looking into it.

    I wonder why downgrading the php fixes it in our situation…

    Will try to find a way to get the WooCommerce login details and follow up that way.

    Thread Starter chewventure

    (@chewventure)

    Ok, I found a solution from https://stackoverflow.com/questions/36079651/silence-declaration-should-be-compatible-warnings-in-php-7

    In my case I had to add arguments to the WC_Product_Variable_Subscription::get_available_variations() function

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Incompatibility between WooCommerce Core and WooCommerce Subscriptions’ is closed to new replies.