Support » Plugin: Easy FancyBox » Incompatibility between jQuery 1.9.1 and FancyBox 1.3.4

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author RavanH

    (@ravanh)

    Hi webists, I’m not allowed to include fancyBox2 in a plugin hosted on WordPress Extend because fancyBox2 does not use the GPL or similar licence. But yea, I’m planning on moving to fancyBox2 by way of allowing users to include it after downloading the script themselves.

    In the mean time, I need to find a reliable way of supporting FancyBox 1.3.4 with jQuery 1.9+

    Could you test the following for me, please? Your help will be much appreciated.

    Append this line to your themes header.php just before the closing </head> tag:

    <script src="http://code.jquery.com/jquery-migrate-1.0.0.js"></script>

    Please tell me if you still get errors…

    Hi RavanH,

    In my case, adding your code, the error is still there.

    Thanks for your work on the plugin.

    Rubén.

    Plugin Author RavanH

    (@ravanh)

    Hi Rubén, can you share a link so I can take a look?

    Hi RavanH,

    I solved the problem downloading the patched file from stackoverflow post in first post.

    But, I have broke again for your testing.

    I filled a contact form in your site with site url.

    Plugin Author RavanH

    (@ravanh)

    Hi Rubén, I have not received any contact form submit from you but if you say the patch by JFK (that’s the answer you are referring to, I suppose) on http://stackoverflow.com/questions/14344289/fancybox-doesnt-work-with-jquery-v1-9-0-f-browser-is-undefined-cannot-read works, I’ll consider it for the next release. Of course I’ll have to test it with other jQuery versions as well 🙂

    I’ve gone in and manually patched the plugin’s version with the link provided. It would be great to have this working in the next version w/ 1.9.1 – I love Fancybox and your plugin makes it a breeze to install but I can’t have it breaking other scripts :[

    Plugin Author RavanH

    (@ravanh)

    Hi Devin, the next release will have either the patched version or will be using the jquery.migrate.js extension.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Incompatibility between jQuery 1.9.1 and FancyBox 1.3.4’ is closed to new replies.