Support » Plugin: Toolset Types - Custom Post Types, Custom Fields and Taxonomies » Incompatability with WooCommerce

  • Resolved munkyhead86

    (@munkyhead86)


    Hello,
    This plugin seems to be conflicting with the ability to edit the product data meta, after the 2.2.2 update.

    Ever since we’ve updated it, we’re unable to edit the data. Disabling the plugin solves it, but creates issues with the content types created using it.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Support Beda

    (@bedas)

    This might be due to a Select2 Conflict but I am not sure.

    Can you provide me the exact steps to reproduce this problem?

    It should possible be steps to follow with a minimal set of plugins (Types and WooCommerce only)

    Then, if I can reproduce that, I will report it to the Developers.

    Not sure…
    Anyway, I’ve downgraded the plugin to 2.2.1, and it works now. So… can’t reproduce at this point. I can assume it was a JS error.

    Plugin Support Beda

    (@bedas)

    Could you pass me the exact steps you did follow?

    It is not good to downgrade a plugin, and anyhow, in a future update this could perhaps get solved (if we know how to reproduce) and you would be able to use updated versions.

    Otherwise you would have to use 2.2.1 forever, right?
    that’s not the goal.

    I know, but I needed an immediate solution 🙂

    In any case, there are the meta fields in WooCommerce, the ones with the product data (price, variations, and so on). After updating to 2.2.2 – they don’t work/react. I can assume it’s a JS error.

    You just click things in the meta area, and nothing happens. The tabs don’t change, you can’t select anything from the select boxes…

    Plugin Support Beda

    (@bedas)

    I tested this with Types 2.2.2 and all seems to work fine.

    We have had renamed Select2 namespaces and omitted a few, which were then fixed in the above mentioned version.

    Can you try again?

    Seems to be working 🙂 Thank you!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Incompatability with WooCommerce’ is closed to new replies.