WordPress.org

Support

Support » How-To and Troubleshooting » Inclusion of class-simplepie.php in class-feed.php crashes site

Inclusion of class-simplepie.php in class-feed.php crashes site

  • After upgrading to WP 3.1 I noticed that my admin dashboard started crashing upon or right after page load.

    I found out that it was when a widget tries to use the fetch_feed() function of /wp-includes/class-feed.php.

    By manually inserting die(); different places in the code, I found out that the error occurs on this line in the beginning of class-feed.php:
    require_once (ABSPATH . WPINC . '/class-simplepie.php');

    An inserted die(); breakpoint on the first line of class-simplepie.php doesn’t fire, so either it is the require_once function that fails, or else WP has a problem with the whole class-simplepie.php file?!

    The string put in require_once echoes to:
    C:\xampp\htdocs/wp-includes/class-simplepie.php
    … which looks ok to me.

  • The topic ‘Inclusion of class-simplepie.php in class-feed.php crashes site’ is closed to new replies.