Support » Plugins and Hacks » [Resolved] Including Value Problem in Field Settings

[Resolved] Including Value Problem in Field Settings

  • Hi. I have a problem when I insert an INCLUDE value in the field; if I write ‘value1, value2’ my form display ONLY the result with the ‘value2’….already if I insert ‘value2, value1’ the result are only value1 (the last value displayed)…how to solve this problem??

    Thank you.



Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author anmari


    remove the spaces

    only use value1,value2
    or value2,value2

    in some cases spaces are valid parts of the field values

    Problem understood but not solved!
    It isn’t a problem of space, the system remove the space from the values…the problem appears only in the fields of ROLES (first_role), in all other fields work fine (for example age,name,email,info,etc)…when I put a filter (with the INCLUDE form) for the ROLES line it doesn’t work good, it is considered always the last value (roles)….there are solutions for this problem??
    Thank youuuuuu!!


    Plugin Author anmari


    Hi Drober,
    I cannot recreate the problem as you describe it.

    I have tried all sorts of combinations of






    and it always works like it should.

    Is there something unusual about your roles ?
    What happens if you try excluding rather than including ?

    Hi Anmari. Thank you for all your work.
    In my situation I use other Roles (created by me) but than have same capabilities of the Subscriber Users…it’s possible is this the problem??
    If i put values in the EXCLUDE form the result is than are excluded only the first value insered, for example: EXLUDE [role135,role724,role618] are excluded only role135, all he others not.

    Thanks a lot!!!


    Plugin Author anmari


    how are you creating the roles ? and how stored in the db ?

    are you using http://codex.wordpress.org/Function_Reference/add_role ?

    are they additional roles (ie each person has more than one)?

    Is problem replicated with normal roles ? if so, try reinstalling the code etc (I have no such problems on my various test systems, so there must be something different or odd about your setup)

    if you think there is nothing unusual about your role setup then:

    if you like you may email me a sql dump of your users, usermeta tables and possibly wp_options table and I’ll see if I can recreate the problem. I may charge a small fee to advise you what the solution is if it is NOT a plugin problem.

    If it is a bug, I will fix it, no charge of course.

    Alternatively see http://wpusersplugin.com/support/. Paid support starts in 1/2 hr increments.

    Hi Anmari. Thank you for your support.
    I create the Roles with the dashboard menu ‘Users->User Role Editor->ADD new Role’ and after I change the capabilities of 2 users with the new Role just created, these 2 users have just only One Role.
    I’v tested this with 2 Roles, one created from me and one default of WP, the Administrator Role.
    I can’t send you DB information about the users, privacy problem; but I solve this problem with another method, I display 2 tables on the same page, the first with included a Role, the second included the other Role, so that…this is my solution. Thank you!!!

    Plugin Author anmari


    Hi drober, I’m glad you found a workaround for your situation.
    It is still puzzling why it did not work for you.
    Which plugin added those menu options for you? they are not native to wordpress as installed from wordpress.org

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] Including Value Problem in Field Settings’ is closed to new replies.