Support » Plugin: Complianz - GDPR/CCPA Cookie Consent » Including reCAPTCHA cookies as functional (always active)

  • Resolved nuevaenword

    (@nuevaenword)


    Hi. I want to include reCAPTCHA cookie as a necessary functional one. What can I do? Thanks in advance.

    Regards πŸ™‚

Viewing 15 replies - 1 through 15 (of 24 total)
  • Plugin Contributor Aert Hulsebos

    (@aahulsebos)

    Hi @nuevaenword,

    Under Wizard – Cookies – Integrations, select reCAPTCHA as third-party. The subsequent question should be answered no, do not block reCAPTCHA.

    This should do it,

    regards Aert

    Thread Starter nuevaenword

    (@nuevaenword)

    Hi. Aert. I did it. I have reCAPTCHA as a service. The pluging didn’t ask me wether to block the cookies or not. At the end reCAPTCHA cookies appear without service and in the “Cookies policy” as pending investigation.
    (mi site is https://prueba.unifilomedia.net/politica-de-cookies-ue/) What can I do?

    Regards πŸ™‚

    • This reply was modified 6 months, 2 weeks ago by nuevaenword.
    Plugin Contributor Aert Hulsebos

    (@aahulsebos)

    Hi @nuevaenword,

    I meant this question, it should always appear when reCAPTCHA is enabled in the above question. https://snipboard.io/w2dxXE.jpg

    Resync with cookiedatabase.org afterwards to describe the service.

    regards Aert

    Plugin Contributor jarnovos

    (@jarnovos)

    Hi @nuevaenword,

    I assume that Aert’s suggestion above helped to stop the blocking of reCAPTCHA before Marketing consent, so I’m marking the thread as resolved for now. Let us know if you require further assistance with this.

    Kind regards,
    Jarno

    Thread Starter nuevaenword

    (@nuevaenword)

    Hi. Jarno. I did what Aert sugests and I have now Google reCAPTCHA as a service. But I have the “_grecaptha” cookie as “pending investigation”. I remind you my site https://prueba.unifilomedia.net/politica-de-cookies-ue/
    As you can see. Under “Varios” appear two cookies which in fact are functional cookies that are settled without consent. They are “_grecaptcha” and “hasConsents”. They both are installed and I need to place them as “Funcionales (siempre activas)”. What can I do? Thanks in advance.

    Regards πŸ™‚

    Plugin Contributor Mathieu

    (@paapst)

    Hi, Just wanted to let you know that the information about _grecaptcha has now been updated on cookiedatabase.org and is no longer “pending investigation” : https://cookiedatabase.org/cookie/google-recaptcha/_grecaptcha/

    With regards to the HasConsents cookie: We are indeed investigating where that cookie comes from. Are you (or have you been) using a plugin called: all-in-one-wp-migration ?

    Thread Starter nuevaenword

    (@nuevaenword)

    Hi Mathieu. Thanks. I can see the “_grecaptcha” cookie is recognised in the page you provide but in my policy it is under “Various”.
    Yes I use “All-in-One”. Thanks in advance.

    Regards πŸ™‚

    Plugin Contributor Mathieu

    (@paapst)

    The information about HasConsent is now updated. A resync with cookiedatabase should do the trick.

    Thread Starter nuevaenword

    (@nuevaenword)

    Hi Mathieu. It doesn’t work. I have resync with cookiedatabase. It recognise all-in-one as a service with its cookie “HasConsent” but I have lost reCAPTCHA as a service in muy policy in spite of being treated as a service in the plugin administration see the link (https://ibb.co/Dpqgdfj. My site is (https://prueba.unifilomedia.net/politica-de-cookies-ue/). Last week I had three cookies (rc::a; rc::b; rc::c) under reCAPTCHA as a service in my policy, and “_grecaptha” under “varios” with no service asociated. Now, all of them exist in cookiedatabase, but in my policy the reCAPTCHA service has disappear and the first group of cookies as well and “_grecaptcha” remains in “varios” with no service asociated. I have cleaned the cachΓ© in mi site and in the browser. But nothing changes. I have other cookies without services as well under “varios”. They are: storeApiNonce pendingTasks and cookies_and_consent_security_policy.
    There are cookies that are settled without consent and are not listed in my policy. They are:”cmplz_marketing”, __stripe_sid and wordpress_sec

    I have another problem reported several weeks ago. I have “Statistics” cookies, but I don’t have Statistic category. Thanks in advance.

    Regards πŸ™‚

    • This reply was modified 6 months, 1 week ago by nuevaenword.
    • This reply was modified 6 months, 1 week ago by nuevaenword.
    • This reply was modified 6 months, 1 week ago by nuevaenword.
    Plugin Contributor Aert Hulsebos

    (@aahulsebos)

    Hi @nuevaenword,

    Let’s start with reCAPTCHA:

    Do you have reCAPTCHA checked under Cookies – Integrations in de wizard, as suggested in this screenshot?

    https://snipboard.io/w2dxXE.jpg

    Selecting reCAPTCHA in this overview should sync the service to your cookie policy.

    regards Aert

    Thread Starter nuevaenword

    (@nuevaenword)

    Hi Aert. Yes I have it, but I don’t have the service in my policy. Thanks in advance.

    Regards πŸ™‚

    Thread Starter nuevaenword

    (@nuevaenword)

    Hi again Aert. After the last update the policy looks much better. I have now Google reCAPTCHA with all its cookies, but _grecaptcha remains as “pending investigation” in spite of being clasified in cookie data org as “functional”.

    I want to remind you there are several “pending investigation” cookies: _grecaptcha, storeApiNonce, pendingTasks and cookies_and_content_security_policy.

    The Statistics category remains missing. Thanks in advance.

    Regards πŸ™‚

    Plugin Contributor jarnovos

    (@jarnovos)

    Hi @nuevaenword,

    The statistics category is only displayed some of the three checkboxes in the Wizard > Integrations > Statistics are left unchecked. That would mean your statistics are not anonymous, and consent would be required.

    A part of these cookies that are currently pending investigation, are cookies that will disappear from the Cookie List eventually, as these are not relevant to visitors on the front-end of your site.

    I would advise to just let Complianz run its scans in the background. It will keep gathering information and gradually adapt to the way your site functions. It seems like your site is still under development and if you, for instance, keep manually re-scanning for Cookies and Services in the Wizard this could interfere.

    At a later stage, when you are nearly finished building your site, you can do a full re-scan and sync with CookieDatabase to fully complete your Cookie List.

    I hope this clarifies, I’ll mark this thread as resolved for now.
    Kind regards,
    Jarno

    Thread Starter nuevaenword

    (@nuevaenword)

    Hi Jarno. This is a bit tricky. Do you mean the statistics category doesn’t appear because I have not checked any service related to this in the wizard? According to the policy the only one statistic cookie I have is “tk_ai” which is anonymous. Do I have to check the box for “anonymously” in the wizard?. Thanks in advance.

    Regards πŸ™‚

    Plugin Contributor jarnovos

    (@jarnovos)

    Hi @nuevaenword,

    If you set “Do you target visitors from Germany, Austria, Belgium and/or Spain?” to “Yes”, you will be asked under “Wizard > Statistics” if you want to ask consent for Statistics. Setting that to “Yes” will enable the Statistics category.

    If you do not target Germany/Austria/Belgium/Spain: the Statistics category does not appear because you have enabled all 3 checkboxes under “Wizard > Statistics”. It will only appear if one of these has not been checked. (Screenshot).

    Kind regards,
    Jarno

Viewing 15 replies - 1 through 15 (of 24 total)
  • You must be logged in to reply to this topic.