Support » Plugin: Yoast SEO » Including “no index” pages in sitemap

  • This issue has been there forever, There seem to be no intention to fix it.
    This happens for Woocommerce pages like cart, checkout …etc

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Support monbauza

    (@monbauza)

    Hi @eiad,

    Thanks for your comment.

    The Yoast WooCommerce SEO plugin does exclude WooCommerce core pages like cart and checkout from the XML sitemap.

    If you’re not running this add-on, you can get similar results by going to the edit screen of these pages and changing the “Allow search engines to show this Page in search results” option under the Advanced tab of the Yoast metabox to No.

    • This reply was modified 1 year, 7 months ago by monbauza.
    • This reply was modified 1 year, 7 months ago by monbauza.

    Yes, but that results 2 “noindex” tags for these pages since they already “noindex”. As I googled around at that time, the advice was not to do that. I suggest making manual exclusion option for your sitemap instead like other seo plugins

    Thanks for the reply though

    Plugin Support monbauza

    (@monbauza)

    Hi @eiad,

    Thanks for following up.

    That’s true. If WooCommerce also outputs the noindex tag you’ll end up with two noindex tags. In this case, it’d be best to exclude the individual pages from the XML sitemap by using the wpseo_exclude_from_sitemap_by_post_ids filter. You can find an example of use here: https://gist.github.com/visualpropaganda/23a694600d870bf66b3499f3ef75dcb9

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Including “no index” pages in sitemap’ is closed to new replies.