Enhanced Menu Editor
Includes suddenly broken. (2 posts)

  1. geoffkb
    Posted 1 year ago #

    I have used includes to insert files into many pages, in some cases the whole content of a page.

    Suddenly the includes have been re-written, a space appears. <?php becomes <? php

    I've disabled the WYSIWYG editor. The only plugin I've installed recently is Enhanced Menu Editor. Could this be responsible? I've deactivated all plugins but most of the includes just appear as text.

    Strangely the includes in widgets are still working. It's a multisite installation and there are includes on other sites still working.

    I'm flummoxed! Could it have been 3.8.2 update?


  2. geoffkb
    Posted 1 year ago #

    I fixed it!

    I had checked the box under the Writing Settings:-

    "WordPress should correct invalidly nested XHTML automatically"

    I unchecked it and that stopped the space being inserted in <?php. Then I did a find and replace on the database to change < ?php to <?php, and we're back to what passes for normal.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Enhanced Menu Editor
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic