WordPress.org

Support

Support » Plugins and Hacks » Testimonials Widget » [Resolved] include_once and session_start errors with premium plugin 1.10

[Resolved] include_once and session_start errors with premium plugin 1.10

  • After updating to the latest version of the premium plugin (1.10), we are getting the following errors on a client site and have had to revert back to the previous stable release (1.9.1), in which there were no errors.

    Warning: include_once(__DIR__/lib/testimonials-widget-premium-cache.php) [function.include-once]: failed to open stream: No such file or directory in /public_html/wp-content/plugins/testimonials-widget-premium/testimonials-widget-premium.php on line 914
    
    Warning: include_once() [function.include]: Failed opening '__DIR__/lib/testimonials-widget-premium-cache.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /public_html/wp-content/plugins/testimonials-widget-premium/testimonials-widget-premium.php on line 914
    
    Warning: include_once(__DIR__/lib/testimonials-widget-premium-form.php) [function.include-once]: failed to open stream: No such file or directory in /public_html/wp-content/plugins/testimonials-widget-premium/testimonials-widget-premium.php on line 915
    
    Warning: include_once() [function.include]: Failed opening '__DIR__/lib/testimonials-widget-premium-form.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /public_html/wp-content/plugins/testimonials-widget-premium/testimonials-widget-premium.php on line 915
    
    Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /public_html/wp-content/plugins/testimonials-widget-premium/testimonials-widget-premium.php:914) in /public_html/wp-content/plugins/formbuilder/formbuilder.php on line 177

    http://wordpress.org/extend/plugins/testimonials-widget/

Viewing 4 replies - 1 through 4 (of 4 total)
  • How did you update to 1.10? I only received an update for the widget but not the premium widget. Now I’m getting a fatal error and it knocked my entire sidebar off.

    That’s easy. We updated using the regular plugin update method. Refresh the updates and it appears. We’re running the latest Testimonials Widget (2.10) and were running the latest Premium version, but had to drop back one release. Otherwise, all other sites are running fine using the latest release of both plugins (standard and premium combination).

    That’s how I updated too. Testimonials Widget updated to 2.10. Premium didn’t update, and I’ve looked everywhere for instructions on updating Premium – can’t find anything anywhere. Total disaster!

    Plugin Author Michael Cannon

    @comprock

    @pennink, I have a fix for the __DIR__ pending release later this week. However, if you download again, the fix is in there.

    Chris, you update Testimonials Widget Premium via WP Admin > Dashboard > Updates and clicking Check for Updates. Then, the rest should be fine.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Resolved] include_once and session_start errors with premium plugin 1.10’ is closed to new replies.
Skip to toolbar